FreePBX 13 and MP3 uploading

Greetings all,

I started working for a VOIP service provider last year, with absolutely no experience running Linux and VOIP systems. I have been following your forums all year, and these threads have helped shape my general knowledge of Asterisk and Freepbx. Without this community, I would have so many unresolved issues that I most definitely would be out of a job. So I’d like to open up my first thread starting off with a huge THANK YOU to everyone who contributes to this !

Now here’s my issue:

We are looking into upgrading our current VOIP infrastructure (cloud-based VM’s) to the most recent stable FreePBX/Asterisk release (Asterisk 13/FreePBX 13). I have followed the how-to for CentOS 6 straight from the FreePBX website. Everything went smoothly during the install, no errors whatsoever.

However, after installing the required modules and getting around to start a basic configuration, I noticed I could not import mp3 files into the Web GUI; both for MOH and System Recording modules. I get an ‘Unsupported File Type’ error. Might I add that i compiled Asterisk with format_mp3.so

Where do you guys figure I went wrong?
Sorry if I didn’t include enough information, I will gladly provide more.

FreePBX 13 doesn’t support format_mp3.so, it’s resource intensive. Therefore we transcode any mp3 to a native format in Asterisk. See: http://wiki.freepbx.org/display/FOP/Installing+Media+Conversion+Libraries

Short: you need to install mpg123

… or transcode your MP3 files to supported WAV format files.

1 Like

When I uploaded some MP3 music files for my on-hold music they were automatically converted. The default was WAV but there were selection boxes for a few other formats. It’s not at all an efficient format but as long as your not uploading your entire music library it shouldn’t be a problem.

Thank you very much for you input. As per your suggestions, I installed mpg123 and it worked. Al I had to do was add a symlink to /usr/bin/mpg123.

My particular distro (RasPBX for the Raspberry Pi) already had mpg123 installed so for me it just worked which was nice.