FreePBX inbound routing

Hello FreePBX Community,

Installation: FreePBX

I have an issue whereby I am unable to route incoming calls based on caller ID. It appeared to me that the provider was just sending the main trunk number regardless of which DID I called.

The provider came back with the following:

"Hi Nick its looks like they are interpreting REQUEST_URI incorrectly , number in To Header is ok but in request_uri number is 02895870100. which they had used as contact address when they registered the PBX . Please can you ask them to use same sipusername as contact address too when they register PBX ? then try test calls "

I am not clear where to check this, is it in SIP settings and perhaps related to the registration string?

There’s an inbound context called from-pstn-toheader that will actually solve this problem for you. Just change the context on your inbound trunk definition and you should be good to go.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.