FreePBX | Register | Issues | Wiki | Portal | Support

FreePBX 13.0.192.19 + Asterisk 13.22.0 - German Telekom (Deutsche Telekom) - no outgoing calls?

siptrunk
Tags: #<Tag:0x00007f749d557ad0>

(Christian B.) #1

Hi,

FreePBX 13.0.192.19 + Asterisk 13.22.0
Registration of Telekom numbers: works OK, shows “Registered” (PJSIP)

Calling out always ends with 403-Forbidden - chan_sip AND pjsip.

There must be something wrong somewhere deep in the configuration.

all variations of username/password (there are several possibilities reported in various blogs…) do not work.

Asterisk is running behind a firerwall and NAT is needed. The external IP can be determined using the dyndns name of the external interface

I really don’t care whether I call out using chan_sip or pjsip - but corrently neither of them works.

Any ideas? There must be a solution, I’m sure …

Regards

Chris


(Dave Burgess) #2

Show us the failure in the logs. That will help.


(Christian B.) #3

well, magic restart helped… scratch the whole box (there was an harddisk error), set up new - works.

no idea why


(Daniel Friedman) #4

Hi @bofh42,

From my experience with Deutsche Telekom (DT), here are my notes for a working SIP trunk (not PJSIP) configuration:

there is a DNS resolving problem (add the record to the hosts file):

217.0.15.67 sip-trunk.telekom.de

*****

Duetche Telekom Supports TCP only and user phone:

host=sip-trunk.telekom.de
defaultuser=551234567890
secret=xxxxxxx
type=peer
port=5060
fromdomain=sip-trunk.telekom.de
fromuser=+4981234567890
canreinvite=no
insecure=port,invite
disallow=all
allow=alaw&ulaw
session-timers=refuse
qualify=yes
transport=tcp

*****
register with tcp and phone as user:

tcp://+4981234567890:xxxxxxx:551234567890@sip-trunk.telekom.de/+4981234567890

****

We need to activate dns srv lookup in sip.conf

Thank you,

Daniel Friedman
Trixton LTD.


(Christian B.) #5

Thanks, but …

I’m not using sip-trunk@telekom.de but a “normal” tel.t-online.de … which is a bit different, it seems


(Christian B.) #6

It really looks like it does not matter what you put into the authentication fields - as long as you are connected from your own DSL/VDSL line.

All variants work at the moemnt.

The “trick” was to complety reboot the asterisk machne as soon as connection problems come up … :frowning:


(Daniel Friedman) #8

Hi @bofh42,

The t-online is a white label of Duetche Telekom and as such my configuration is correct. Anyhow, here is another source for interconnecting to DT with Asterisk: https://www.voip-info.org/asterisk-settings-for-t-onlinede/

Thank you,

Daniel Friedman
Trixton LTD