FreePBX 11 Not writing to /etc/dahdi/system.conf Properly

I downloaded the FreePBX iso a couple days ago (Stable-5.211.65-13
Release Date-06-03-14 FreePBX 2.11, Linux 6.5 Asterisk 1.8 or 11 ) and was trying to use the Dahdi Module system Settings to add echo cancellers to my PRI’s. It should be possible to to hit the green “+” circle and an echo canceller entry for each PRI. However, only the last entry I made in the system settings was ever written to /etc/dahdi/system.conf Here are the instructions I followed:

  1. In FreePBX, mouse over “Connections” and then click on “Dahdi”
  2. Once the Dahdi config page opens, look to the upper right hand corner for a box that is labeled “Settings”
  3. Click on “System Settings”
  4. This willopen a page with two fill in boxes with a equal sign between each box.
  5. In the first box enter
  6. In the second box enter <mg2,1-23>
  7. If you have more than one span, click the green “+” and repeat steps 4 & 5
    8 When finished, click save
  8. Apply changes
  9. Restart Dahdi using the link at the bottom of the page

These instruction worked in earlier versions of FreePBX (2.8) but not 2.11.

For proper consideration please submit a bug in our issue tracker at Please note all bugs, improvements, and feature requests must come through a bug report. If you also have a resolution or code for a new feature code can be submitted by way of patch or pull request on github. Please note to submit code you must complete a code submission agreement. All github pull requests should reference an active ticket.