Free PBX Crased.... AGAIN! :(


(Joshua Herbert) #1

Is there anyway to fix this??

SHMZ 2.3

Virtual Box V4.3.22


(Andrew Nagy) #2

Looks like a black box. Am I missing something?


(Marbled) #3

Could it be possible the forum software censored the image given its name? :wink:

Have a nice day!

Nick


(Joshua Herbert) #4

Okay, this is the real problem Im having before the System Error.

Cornmanager encountered 1 Errors
/var/lib/asterisk/bin/module_admin listonline (1)

I’ve tried chmod 777 var/lib/bin/module_admin
Response was "chmod: Missing operand after '777/var/lib/bin/module_admin

Please help!!


#5

try
chmod 777 /var/lib/bin/module_admin - the leading / is important.


(Dave Burgess) #6

Also, unless you are getting a write error on the file (which shouldn’t be an issue for a cron job) you should never chmod a file to 777. It is almost always more correct to use either ‘555’ or ‘755’. If you are getting a write error on a file, you need to adjust who owns the file and use 644 as the mode. Blindly using ‘chmod 777’ is one of the ways you can get hit with a $10000 phone bill.


(Joshua Herbert) #7

Thank you all so much for your help!

I’ve tried “chmod 555 /var/lib/asterisk/bin/module_admin”

it didn’t do nothing.

Same for “chmod 555 /var/lib/bin/module_admin” it says chmod can’t access /var/lib/bin/module_admin no such file or directory.

you have new mail in /var/spool/mail/root

I went to the directory and it said permission denied.

Thanks again!! Cheers!!


(Andrew Nagy) #8

So it did something?

Please to a chmod +x against those files. I think @cynjut meant 655. Anyways but the +x will make them executable which is what you want.


(Joshua Herbert) #9

My apologies for the late reply.

So what command would I use to make this executable.


(Andrew Nagy) #10

Use… chmod +x


(Joshua Herbert) #11

No luck… :frowning:

2 out of 4 soft phones has trouble connecting since this error.


(Andrew Nagy) #12

You told everyone here that “Free PBX Crashed”

Then you said you couldn’t run module_admin.

Now you are reporting a different error.

Whats the real problem?


(Joshua Herbert) #13

It’s been a couple of years since I’ve made this post. But I think that I fixed it. I eventually Re-Installed Free PBX on a new Machine. I am not using virtualBox anymore to run FreePBX on a 2011 Mac Mini running OSX Yosemite. It was too laggy and it slow my Apple Computer down. What I did was install Free PBX on a computer tower that I have found. It works well. However, I am attempting to use Free PBX wirelessly with my home internet. Can anyone point me into the right direction on how I can go about this?? Thanks alot!


(Itzik) #14

I’m against having a VoIP server wirelessly.

But if you want to do it, you’ll need hardware that supports WiFi.

Finally, your last post is unrelated to the original topic, plus it’s 4 years old.
Please create a new post


(Joshua Herbert) #15

Would a USB wifi Adapter work?


(David55) #16

You’ll also need WMM, to stand a chance of acceptable voice quality over wifi.


#17

Why do you need to do that? You normally would not need physical access to the machine, so just put it near your router and connect it with an Ethernet cable.


(Joshua Herbert) #18

I am looking into purchasing a Polycom 4880 witch is a handheild wi-fi wireless ip phone.
It’s by spectralink. And it’s also a sip firmware.


#19

If the (wired) network to which you connect your PBX has decent Wi-Fi, you shouldn’t have to do anything special – the 8440 will just work. However, achieving nearly perfect voice quality may require adding access points for better coverage and keeping high-traffic devices such as security cameras and set-top boxes off of Wi-Fi. Also, interference from neighboring networks could be a problem.


(Joshua Herbert) #20

Well, the good news is that my modem is wi-fi! So I shouldn’t really have problems connecting. I use Zoiper on my personal devices and it works well.