Free PBX 2.8.1.4 on i386 VPS - Hylafax server won't start

Hi

I got Free PBX installed on a i386 Centos VPS using Open VZ. The installation
went through without problems until I wanted to add fax functionality.

In the extension pages my Free PBX reports:

ERROR: No FAX modules detected! Fax-related dialplan will NOT be
generated. This module requires Fax for Asterisk or spandsp based
app_fax or app_rxfax to function.

Tried Fax for Asterisk from Dignum, but it did not work because
(obviously) no eth0 can be detected on an Open VZ VPS. Tickets to their
support remained unanswered.

So I tried Hylafax and IAXmodem, followed these instructions
http://www.walternet.com/index.php/component/content/article/41-network/86-asterisk-hylafax-iaxmodem-setup
word by word. I created the IAX extension, changed the port and config.
as suggested.

Result is service iaxmodem starts and runs on the correct port,
hylafax queue manager also starts up fine, but hylafax server fails.
Funny thing here is that when I reboot the system the hylafax server
appears to start (but does not work because I can’t select NVFaxdetect
from Free PBX Web interface).

This is what I get when I try to stop / start it:

[[email protected] ~]# service hylafax stop
Shutting down HylaFAX queue manager (faxq): [ OK ]
Shutting down HylaFAX server (hfaxd): [ OK ]
[[email protected] ~]# service hylafax start
Starting HylaFAX queue manager (faxq): [ OK ]
Starting HylaFAX server (hfaxd): [FAILED]
Restarting HylaFAX modem manager (faxgetty): [ OK ]
[[email protected] ~]# service hylafax stop
Shutting down HylaFAX queue manager (faxq): Could not open null device
file /dev/null. [ OK ]
Shutting down HylaFAX server (hfaxd): [FAILED]

I believe the /dev/null is what causes hylafax not to start correctly, did anyone here ever get fax funcionality working on a VPS?

Regards
Christian