Framework update fails. new raspbx install


(Mark X) #1

hi people,
I’m totally new to this - just want to have a play and set up a system initially for home use.
Just installed raspbx.
In the update page I see a message that there is a security issue and I need to upgrade the framework

FreePBX Framework 15.0.16.22 Stable Sangoma Technologies Corporation [GPLv2+] Online upgrade available (15.0.16.41) Vulnerable, Requires: 15.0.16.38 ]



|Publisher:|Sangoma Technologies Corporation|
| --- | --- |
|Packaged (Released):|01/17/20|
|License:|[GPLv2+](http://www.gnu.org/licenses/gpl-3.0.txt)|
|Signature Status:|Good [(What Does this Mean?)](http://wiki.freepbx.org/display/F2/Module+Signing)|
|Fixes Vulnerabilities:|SEC-2019-000, SEC-2019-001|
|Description:|This module provides a facility to install bug fixes to the framework code that is not otherwise housed in a module|
|More info:|[Get help for FreePBX Framework](https://www.freepbx.org/freepbx-help-system?freepbx_version=15.0.16.22&freepbx_module=framework)|
|Track:|Stable|
|Action:|No Action Download and Upgrade to 15.0.16.41|

Please wait while module actions are performed

Downloading and Installing framework
Downloading framework 16047472 of 16047508 (100%)
Error(s) downloading framework:

  • File Integrity failed for /var/www/html/admin/modules/_cache/framework-15.0.16.41.tgz.gpg - aborting (GPG Verify File check failed)

Any suggestions? Tried multiple times, not out of space on the pi


#2

It’s not you. I get the same error in web and the command line.

Issue: https://issues.freepbx.org/browse/FREEPBX-20977 seems related. Go add a comment and a vote.


(Mark X) #3

Thanks.

I couldn’t see anything obvious, but it seemed bizarre that an update touted as essential security just wouldnt work…


#4

Still an issue this morning. Got around it by manually extracting the file into /var/www/html/admin/modules and “fwconsole ma install framework”


(Oliver) #5

Here is how to solve this:

The problem is, that a new installation come with Framework 15.0.16.27. Starting with Version 15.0.16.38 of framework, the GPG keys are updated (just have a look at the changelog and your error messages). You cannot install, because system is trying to upgrade to framework 15.0.16.42, which GPG key is not known, until 15.0.16.38 is installed. Therefore all depending modules will fail (refuse) to install.

Simply open your web interface and go to “Module Admin” in Admin Tab. Now click on “CHECK ONLINE”. After that, scroll down to “FreePBX Framework” and expand it by clicking. You will see “PREVIOUS” on the left side. Click on it. Now, you see the previous releases, with there version numbers and a “ROLLBACK” button.

Don’t be confused here, the button is named ROLLBACK, but we do an upgrade by clicking it. So, now click the ROLLBACK button for version 15.0.16.38 (DO NOT USE ANY OTHER VERSION).

The installer now will upgrade to 15.0.16.38, which WILL SUCCEED. After this, you are able to upgrade your framework to the needed version 15.0.16.42, without any problems. After that, you can install your favorite modules again.

And now, hold your applause…. your welcome :slight_smile:


(Lorne Gaetz) #6

Interesting. You can also do it at the command line with:

fwconsole ma downloadinstall framework --tag 15.0.16.38 
fwconsole ma upgrade framework

(Matthew Fredrickson) #8

Hey guys,

Just wanted to apologize about the trouble. I’ve got someone that’s going to look into this to see if we can improve this for other people that run into this specific issue.

@OliverW thanks for helping him with the solution with this.

Matt


(D Dunbar) #9

Thank you so much for the clear instruction on how to remedy this annoying issue!


(system) closed #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.