Framework Install Issue

Asterisk 16 Freepbx 14

Received a notification about a bunch of module upgrades including framework

Went in to do the update and got the following error for Framework (which is now disabled)

fwconsole ma install framework
Updating tables admin, ampusers, cronmanager, featurecodes, freepbx_log, freepbx_settings, globals, module_xml, modules, notifications…Done
installing files to /var/www/html…done
installing files to /var/lib/asterisk/bin…done
installing files to /var/lib/asterisk/agi-bin…done
Checking for upgrades…
2 found
Upgrading to…
-> Running PHP script /var/www/html/admin/modules/framework/upgrades//

In upgrade.php line 3:

syntax error, unexpected ‘(’ in /etc/asterisk/asterisk.conf on line 2

ma [-f|–force] [-d|–debug] [–edge] [–stable] [–color] [–skipchown] [-e|–autoenable] [–skipdisabled] [–snapshot SNAPSHOT] [–format FORMAT] [-R|–repo REPO] [-t|–tag TAG] [–sendemail] [–] []…

Current framework version is and the latest is

Can you please help me fix this


Try running fwconsole reload and then fwconsole ma upgradeall

This might fix it for you.

unfortunately no – got the same error

Fix your asterisk.conf file. The error tells you what’s wrong

Andrew – here are the first 12 lines of the asterisk.conf file – i dont see an extra ( on line 2?

astetcdir => /etc/asterisk
astmoddir => /usr/lib64/asterisk/modules
astvarlibdir => /var/lib/asterisk
astdbdir => /var/lib/asterisk
astkeydir => /var/lib/asterisk
astdatadir => /var/lib/asterisk
astagidir => /var/lib/asterisk/agi-bin
astspooldir => /var/spool/asterisk
astrundir => /var/run/asterisk
astlogdir => /var/log/asterisk
astsbindir => /usr/sbin

Really? You dont?

Andrew – i am not trying to be rude or obtuse – and i really appreciate all the help you provide here – but i am not understanding your comment

These are lines one and two:

1 [directories](!)
2 astetcdir => /etc/asterisk

How would you like me to modify lines 1 and or 2 exactly?

Looking at the same file here it looks the same as my file

So sorry to bother you again with something so trivial –


A post was split to a new topic: System Crashed

The error is

It’s not talking about an “extra” “(”.

Remove the (!) that is in your file.

1 Like

That did the trick!

Thank you for your time and assistance

I have tried to upgrade the framework module via GUI , however ;

"syntax error, , unexpected ‘(’ in /etc/asterisk/asterisk.conf on line 2\

seems there is a bug here

@rideous nope not a bug. You’ve copied your asterisk.conf file from a sample file. This is not in any of our wikis or documentation. You can fix the issue by looking above at this thread

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.