Framework broke my FreePBX admin GUI

I upgraded our FreePBX framework module to and an the middle of the install it died. I ended up at a blank (no error, no nothing) web page http://myasteriskip/admin/config.php. No I have no GUI whatsoever. Even the ARI shows a blank page.

The asterisk server and phones are still working, just no web site GUI. I’ve restarted the server and still the same issue. It does prompt me to authenticate when going to the admin site, but just takes me to a blank config.php page.

Any suggestions for getting the gui back?

I am having the same issue with a new install I just performed from the Net Installer. I assume it has used the newest packages, and after I was prompted for the admin user/pass, etc. I could not get to the FreePBX Admin page. I get an HTTP 500 Internal Server Error instead (after being prompted for the username/password).

me too

I also have this issue.

After upgrading the following modules I receive an HTTP 500 Internal Server Error.

Framework ->
Core ->
Paging ->
Backup ->

When I try to do a ./module_admin reload, I get the following:

Error(s) have occured, the following is the retrieve_conf output:
exit: 255
PHP Fatal error: Call to undefined function fpbx_framework_autoloader() in /var/www/html/admin/modules/sysadmin/ on line 0

EDIT: I would also like to mention the system is from the distro ( with no other changes or modules added.

That is the same error my log file shows.

sorry :frowning:

you should be able to update it through the CLI version of module_admin to a new framework module which will fix it.

/var/lib/asterisk/bin/module_admin upgrade framework

Just checked, it is fixed in released about 10 minutes ago.

To update:

cd /var/lib/asterisk/bin
./module_admin download framework
./module_admin install framework
./module_admin reload


cd /var/lib/asterisk/bin

./module_admin upgrade framework

worked for me