FPBX12/Asterisk13 - SCA's, baby

Good afternoon all. So, quite an exciting thing for me - finally got all my weirdness with PJSIP corrected, thanks to TM1000 (Andrew). Now, I’m ready to play with the long-awaited Shared Call Appearance feature. I’ll be the first to admit, I’m not quite sure how to activate it.

Anyone have some experience playing with this in FPBX12/*13?


Their is no such thing. I think you are very mistaken here. FreePBX has no such thing nor does Asterisk

So, thats really disappointing for something so mature to be lacking such a key feature - by not offering support for it, its excluding a huge segment of the population that would be most likely to adopt Asterisk (small businesses that don’t need PBX-style functionality. I understand the nature of SIP may make that a bit more difficult to code for, but somehow Broadsoft pulled it off.

I had heard for a while that *13 was going to finally fill this deficiency, so its kinda disappointing to hear that it doesn’t exist. Though, there’s a part of me that thinks its so flexible, it could be made to work. Then I found this:

This is somewhat old, and they go out of their way to state it can act flaky, but that it does work.

I then hopped into my current FPBX12/*13 install and saw:
CLI> core show applications like sla
-= Matching Asterisk Applications =-
SLAStation: Shared Line Appearance Station.
SLATrunk: Shared Line Appearance Trunk.
-= 2 Applications Matching =-

So it looks like some of its there, and I’m also betting that from 1.8 (when this doc was written) to 13, they’ve fixed some of that “flaky” behavior and it may actually be a bit more reliable than it was.

So if it didn’t truly end up coming out as a feature in *13, anyone have experience pulling it off with coding magic? Its obviously been done before in varying degrees, according to the linked doc above…


1 Like

Among others things, in asterisks implentation of SLA (which they do not actively work on) transfers will hangup. Meaning you can’t do a transfer when doing an SLA in asterisk.

In 12 and 13 multiple phones can register against one endpoint but that is usually not what people think of when they think of SLA

Yeah I saw the transfer thing, but not sure that’s a big deal since its supposed to emulate key system functionality (where everyone would have those appearances). But the multiple registrations, I played with, and it of course won’t let you hold/retrieve. The big thing for folks that need this is the ability to barge in on an existing call, which it looked like it took into account with an element of the conference module.

I will say this. From a development standpoint we are more than willing to accept any patches and/or notes you’d like to give on it. With FREEPBX you can play and work on these things in the custom conf files until you get it working. From a business standpoint it’s not something schmooze is actively focused on at the moment because no one really uses it much and we have a lot of other projects going. But don’t take that as a no!

Really as is with most of freepbx a module could do the SLA setup. It would be something to look into at some point.

So talking to a Digium employee about this. SLA is written as part of “meetme” which has a supported level of extended so Digium aren’t even supporting it in favor of “confbridge”. Because it uses meetme it requires DAHDi. Along with that the code base for the SLA components of meetme have not been touched since Asterisk 11

The last commit I see against SLA was on Wed Jul 10 01:49:41 2013

You can look for yourself if you wish:


Since it was written in meetme if makes me believe that the functionality could be implemented in confbridge by dynamically generating a confbridge (which is allowed). So using custom.conf files in freepbx you should be able to emulate something very similar to SLAs using this workflow

  1. Call comes into FreePBX
  2. Route to dynamically generated confbridges
  3. BLF subscribe to those bridges
  4. when you hang up detect and kill confbridge

Thats a very basic workflow.

I am surprised I missed this thread. SLA and Shared Extension should not be used together.

I don’t know any business that wants to barge in on lines. If they do then they should have a key system or a Walmart phone with two or four lines. JUst because FreePBX is free doesn’t mean that it is appropriate to run it in that environment. Trust me, they will hate it.

Now, in an Enterprise environment the ability for an admin to have an extension appearance of their boss on their phone so the boss can put people on hold and the admin can pickup up. That is a key feature and will continue to be a big gap for Asterisk.

The good news is PJSIP supports multiple registration and it works great. So the only part left is the BLF list support for extension state with Broadsoft extensions.

Now we can bang on the PJSIP folks to finish that work. Possibly a more receptive audience.

I could So use some help. THE WIFE WANTS TO HURT ME. I thought hey here is a good idea nine cisco phones 7941g(6) and 7961g(3) and freepbx. These should just plug in and work out of the box. OH wrong was I. I have the POE switch in the bedroom with 9 phones some on sccp which Freepbx See’s and some some with sip that it does not and two phones that worked till I TRIED TO CHANGE FIRMWARE. TFTP on the freepbx box is a lose to me I have no ide how to get the correct firmware into the folder on the linux. Plus we are now 9 weeks prego. NOW she really wants this project moved yesterday. Any please help.


I doubt you are both 9 weeks pregnant but I bet she is.

I would be divorced if I had a PoE switch and a server in the bedroom.

Anyway, you already said the problem, you need to follow one of the 1000’s of Cisco firmware tutorials on the Internet and read the man page for tftpd (suggest reading the xinetd.d tftp init script so you know how it starts and stops).

The answers are in the man page on how to operate tftp.

1 Like

So I was able to update the phones at the latest SIP software and now they just won’t register.

I could be doing drugs but I think i recall needing to do tcpenable=yes in asterisk sip settings and then the phones registered, (if config file is setup and served from tftp correctly).

Shorten the secret that freepbx generates for the extension by a few characters. Then make sure that is configured for the Cisco phone. Freepbx has a habit of generating a too long of a secret that Cisco phones can not handle.

Note that the secret length is controllable in advanced settings in 13.

Lorne, thanks, that is very good to know.

1 Like