FPBX 14 bypasses network input screen at installation

I have attempted to install FPBX 4 times and each time the screen where I need to input HDD information and Network information just flashes before my eyes then carries on installing FBX. The result is that FPBX14 seems to be installed however I cannot access the GUI as an IP address has not been assigned. I have accessed the router which lists all connected devices and sure enough FBX14 is not connected.
As I say this has happened at least 4 times with the same result.
Any help would be appreciated

This discussion is about the sangoma 7 distro release. It has nothing to do with freepbx 14. Please clarify that.

Are you saying that is question is in the wrong place???

What i am trying to install is described within the download area as

is this not FreePBX 14?

It is but your problems are not FreePBX 14 problems. In fact your problems are happening well before freepbx 14 is installed. They are distro problems.

So there is a fault within the distro? or I have a problem with the host machine which I need to fix before I progress.?

How do distro problems get fixed?

No. The hard drive setup and network setup is automatic. It defaults to DHCP. If you want to define these things yourself you need to select Advanced Install when presented with the list of options on first boot.

OK thanks

Installed SNG7-FPBX-64bit-1607-6 by selecting “advanced”…I was able to input static IP along with gateway.
booted after install and logged on under root.

It does not display the IP input at installation and gives me a message
"Cant find FreePBX\Modules\Sysadmin ::: mkdir(): Permission denied"
Current network configuration
No interfaces found

Access to the router shows that FPBX has an IP of (static IP) however it cant be access via a browser. Just times out.
Any ideas?

I’ve noticed that something strange is happening with iptables - it’s being enabled automatically.

Try ‘service iptables stop’ and you’ll be able to get in immediately.

thanks Rob,
"service iptables stops"
returns " redirecting to /bin/systemctl stop iptables.service

login in at roots does not provide IP address and router does not display connected device
cannot access GUI - browser times out (understandably)
I will reinstall and try again

Rather than set IP I will leave it on DHCP

That is unexpected. Can you provide a screenshot (take a photo with you phone or something?)

Reinstalled leaving IP to DHCP and I get something similar.
I have taken a photgraph

‘No Interfaces Found’.

Your machine doesn’t have a network interface that’s compatible with RHEL 7 … What sort of network card does it have? (‘lspci’)

I dont know and I am not sure how I can find out… No documentation…unless I can find out via the root directory?
I have the same problem with Elastix 4

run ‘lspci’ … probably ‘lspci | grep -i net’

I am a linux newby
How should I input this command?
I am in the root directory now


lspci | grep -i net

That will tell you what network cards are in that machine

The ‘|’ is shift-and-the-button-above enter. It’s normally the \ key, but push shift while you push that and you’ll get | which means ‘feed the output from one command into the input of the next command’

I have tried various spaces within the command and all I get is

-bash: ispci: command not found

Are you typing I-for-indian or L-for-Lema as the first character? (It’s L-for-lema)

00:07.0 NVIDIA Corporation MCP61 Ethernet (rev a2)