Fpbx 13.x remote phones from one site not able to register to fpbx


I’ve got a fpbx 13 box hosted in the cloud and I’ve got about 4-5 clients running off the same server. All the client devices are connecting fine, except for one client. From the obihai phone it says: "Register Failed: No Response From Server (server=x.x.x.x:5060; retrying).

I’ve tried:
-checking responsive firewall and don’t see any client’s blocked there
-stopping responsive firewall from the gui, then seeing if client will register-no
-restarting firewall from cli using “fwconsole firewall stop
fwconsole firewall start”
-put in the client wan ip as filter in the log tab on the gui, but it returned nothing (in the last 500 rows at least).
-added the client wan ip to trusted sites on RF

I’m not sure where or what is blocking it, but I’m stuck…Please help.

I suspect perhaps they are running a dynamic public ip, not static & perhaps their wan ip changed and their extensions were already registered as the original ip, so when the ip changed, they were blocked, but I’m not 100% sure, not sure where to check this out.

All other end points at other sites are working fine, just this one site isn’t.

Any advise?

oh also, I’ve pinged google.com & my fpbx server’s wan ip from the clients lan & both are successful.

In the extension settings, check if NAT is set to “yes”, it’s in the advanced tab

Also, the router at client side, check if “sip alg” is disabled

Don’t have access to client’s modem/router right now, but it has been working fine up until today.

extension > advanced > nat mode: yes is set on their extensions.

If it was working… are you sure the client side hasn’t got a new ip from their isp? Sometimes that happends

Well that’s what I suspect, I’ve added their current ip to the trusted networks on the responsive firewall but still the devices are not connecting.

Ask them to disconnect the phones from the power and let them bootup again… you should be able to see the incoming traffic or ask them what their current wan ip is

I’ve got the wan IP, where do I go in logs (which log) to check for the registration?


Change their old ip to the new in the firewall. Also set to trusted

After a submit and the red box on the right upper corner, go to reports, asterisk info and go to chan_sip or pj_sip…

The extensions should be coming in there from the new ip

the old ip was never added to responsive firewall, i’ve only added the new ip since today.

I dont use the RF, because i know where all my extensions are coming from, so i add the ip to the trusted zone…

But are your phones connecting?

phones from this client site NO, phones from all other client sites Yes

Wait a couple of minutes, and check again…

Am here and not (yet) going away

Are the phones online?

No, still on online.

also, I did an amportal restart from the cli but that doesn’t seem to change anything.

How are the phones connecting… trought the internet or using vpn or??

still getting this error on the phones: Register Failed: No Response From Server (server=x.x.x.x:5060; retrying)

through the internet

Let me see if i’ve got skype on my laptop,

so even creating a new extension and assigning one of the phones to the new extension, it won’t register to the server, so this eliminates my theory that they have a dynamic ip from their isp and the extensions are binded to the old ip.

I’m beginning to think that something is going on the client’s site, with their modem.