Forcegreetings=yes doesn't work

I am trying to force a new user to record a new vm greeting on an exisiting extension and voice mail account by using forcegreetings=yes in vm options and assigning the extension as the voice mail password.

This doesn’t work though.
When user logs into his voice mail he gets “Welcome to comedian mail. First I will guide you through a short setup process. Please enter your new password followed by the #key.”

That’s it, no prompt to record a new greeting. What am I missing?
(Voicemail 13.0.54.20).

Did you set the password the same as the extension?

http://www.asteriskdocs.org/en/3rd_Edition/asterisk-book-html-chunk/Voicemail_id263499.html

forcename=yes
forcegreeting=yes
vmpassword=voivemailboxnumber

Did you actually do that? Because when the password matches the voicemail mailbox it makes the wizard run when they login into the mailbox for the first time. The first they are they made to do is change their password, then after that they are asked for each of their greetings to be recorded.

So did you do the entire process?

Yes, I did that.
I changed the password to be the same as the extension and set forcegreetings in voicemail admin and see the setting in voicemail.conf:

5315 => 5315,Johann test,forcegreetings=yes|attach=no|saycid=no|envelope=no|delete=no

Upon dialing into the voice mail it plays the “new user” announcement, then prompts for a new password but never for a new greeting:

– Executing [*[email protected]:120] VoiceMailMain(“PJSIP/5315-0002ba07”, “[email protected],s”) in new stack
– <PJSIP/5315-0002ba07> Playing ‘vm-newuser.g722’ (language ‘en’)
> 0x7f18f4ab0f00 – Strict RTP learning complete - Locking on source address 10.124.193.90:12002
– <PJSIP/5315-0002ba07> Playing ‘vm-newpassword.g722’ (language ‘en’)

OK so did you enter a new password to go to the next step? If you did what was the next prompt, step you hit? You showed a snippet of the call but not the full call. So what happens after the password prompt?

Scratch that. I forgot forcegreetings only forces the recording of the name not the actual greetings for unavailable and busy. Probably because the name greeting is used by other features of the voicemail app and other apps in Asterisk.

So to record those greetings you have to go into the admin menu and manage the greetings like normal.

Ah ok.
So there is no way to force a user to record a new greeting upon login into an existing vm account that has been used before, it has to be done via UCP or the user has to log into the vm and navigate the regular menu and change the greetings that way.

Or on terminating a box,

rm -rf /var/spool/asterisk/voicemail/default/NNNN

Also, It stuck me that as I have never had a trouble with that same password thingy, it has always been in my general settings . Just a thought.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.