Force FreePBX to press 1 when answering


#1

I have a scenario where I must forward a Telus Phone System extension to FreePBX. The forward works but the Telus system plays a recording asking to press 1 to accept the call. So since FreePBX does not “press 1” automatically, the phone call goes back to the Telus voicemail.

Is there a way to force FreePBX to dial 1 when a call comes in ? (it’s a temporary situation)


(Dave Burgess) #2

The inbound call context can be set to anything you’d like, including custom contexts that do a myriad of things. I’m sure there’s a way to play back a ‘dialed 1’ to the incoming call after answer and continuing the call from there. There will, no doubt, be some measure of holding your tongue just right, but I’m sure it can be done.


#3

First, can you distinguish calls from the Telus, either by caller ID (if the Telus does not spoof the number of the original caller), or by using a dedicated DID?

Create a System Recording consisting of one second of silence followed by 0.2 seconds of DTMF 1, e.g. using Audacity, and upload it to your PBX.

Create an Announcement using said recording, that routes to your Extension, Ring Group, Queue or wherever you want the forwarded calls to go.

Then, set up the Inbound Route for these calls to route to that Announcement.


(Lorne Gaetz) #4

Alternatively, a Custom Destination that receives the inbound call that goes to a context like this:

[from-telus-playdtmf]
exten => s,1,Noop(Entering user defined context from-telus-playdtmf in extension_custom.conf)
exten => s,n,Answer
exten => s,n,Wait(3)   ; how many seconds (if any) to delay 
exten => s,n,SendDTMF(1)
exten => s,n,Return

Enable the return option in the Custom Destination and choose where you want the call to go next.


#5

Thanks for all the suggestions. I was able to find a way to disable the required “dial 1 to accept the call” option from the Telus side, but I’ll keep this info for the future.

Thank you again !