For lack of RTP activity in 31 seconds [SOLVED]


(Claudio Pelosi) #1

I am investigating a problem on the transfer and I am finally seeing the bottom of the tunnel …

In practice, after having solved several other problems, the transfer call “* 72” now appears to be taking place.

The audio does not pass the la chimate remains open 31 seconds

Going to the log here is what it looks like:

[2020-05-25 11:11:11] NOTICE [1883] chan_sip.c: Disconnecting call ‘SIP / 0108933606_out-00000075’ for lack of RTP activity in 31 seconds
[2020-05-25 11:11:11] NOTICE [1883] chan_sip.c: Disconnecting call ‘SIP / 0108933605_in-00000074’ for lack of RTP activity in 31 seconds

It would seem an RTP communication problem

The problem occurs both on a machine behind a draytek router with DMZ on the PBX and on a machine in the cloud when without any nat

Someone manages to give me an idea, thank you all for your collaboration


(Claudio Pelosi) #2

Still some clarifications
The call remains open 31 seconds before dropping
The audio however in those 31 seconds is not present


#3

turn on rtp debugging to see where the media is being sent/received


(Claudio Pelosi) #4

Found the problem!
The provider I am using is CloudItalia and it does something I did not expect, doing the transfer activates a connection from an IP that was not included in the white list of my firewall
I noticed it thanks to tcpdump …
Sitemato this all went wonderfully …


Transfer with abnormal behavior [SOLVED]
(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.