FOP2 WebRTC with Asterisk 18.3.0 and FreePBX15 working settings and a question


(Greg Snover) #1

Ok - with a little help from this post: WebRTC - Does it work with the latest FreePBX? — FOP2 Forum I got it working - A couple of settings he lists are not necessary so I will post here the necessary settings so if anyone finds this post, they know how to get it working:

Set up a Standard PJSIP extension, but under Advanced:
image

He calls for rtcp Mux to be turned on - in my testing, that was not necessary.

image

He also calls Enable WebRTC defaults to be turned on - I haven’t found that needed either.

Without this, you get no audio whatsoever - not even one way in my config. Here is my question - why is this not recommended - I have been Googling and reading for an hour and nowhere can I get a definitive reason why this is showing as not recommended - Digium Folks?

image

Make sure you select your certificate below this and turn it on.

This makes the WebRTC phone in FOP2 work quite nicely - I am going to pair it up with a physical phone now and see if a phone works properly with this extension config.


Third party webrtc phone with FreePBX
FYI - FOP2 License Revoke for moving to a new machine
(Joshua C. Colp) #2

WebRTC configuration is incompatible with normal phones, you can’t use the same PJSIP extension for it. This is primarily due to the use of DTLS-SRTP in WebRTC, while phones either use no encryption or SDES-SRTP.


(Greg Snover) #3

That’s a real bummer - Would this config be incompatible with Sangoma Connect also?

Yup! Just tried - So this “Extension” would only be for FOP2 and nothing else - that would be usable in some situations (Call-Center Agents using it as an Agent Phone?) or a business where they didn’t want Hard Phones at all.

UCP works with this extension config, but I just checked - in either a “Normal” config or with this config, when you make a call in UCP, it doesn’t update your status in FOP2 - If I make a call from UCP, it doesn’t show that I am on the phone.

Sigh…


(Joshua C. Colp) #4

To the best of my knowledge Sangoma Connect does not use WebRTC, and is more akin to having behavior like a normal phone vs WebRTC.


(Itzik) #5

If devices and user mode would’ve been supported AND you’d be able to tie multiple devices to a user, then we could set different settings for each device.


(Greg Snover) #6

Funny you should say that - I had the same idea - so I loaded up devices (without changing modes) and looked at the settings on the UCP/ZULU Device for my extension - it’s already set to almost all the settings I detail above:
image

image

image

image

But…when I changed the settings to match what I had figured out in the Extension Setting to make it work, it still didn’t work - I am guessing since the machine is not in D&U that the extension settings are overriding the device settings.

It’s really a bummer too, because FOP2 with a softphone is actually a pretty nice Web UC solution.


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.