FOP2 flop

I’ve got my FOP in a mess, I was hoping someone could help me straighten it out.

I’m trying to get FOP2 installed. I initially tried following the intructions on the FOP2 web site, i.e. downloading the tarball and running make install. Also downloaded the FOP2 admin module from there, which installed and was functional, but no clue about where I access the FOP2 web pages from.

So then I discovered there was an RPM, so I tried ‘yum install fop2-freepbx’ which seems to work OK, except that it didn’t replace FOP 1 I still get FOP 1 from the web portal, even after rebooting the server. Also, the RPM seems to be out of date with repsect to the FOP 2 tarball and admin module, which has some additional features for editing user templates.

So it looks like FOP 2 might be installed OK, but just the freepbx portal integration hasn’t quite taken.

What is the correct procedure to move from FOP 1 to FOP 2, please?

PBX Firmware:
PBX Service Pack:

–Tim Long

They are two separate products. There are various tips in the FOP2 FAQs at

Checkout FAQ:
Can I monitor FOP2 status from FreePBX dashboard instead of FOP1?
to make FreePBX monitor FOP2 if you like…

I appreciate they are two products, but the FreePBX distro used to include FOP 1 and it is clear that is no longer going to be the case, so it is necessary to update to FOP 2. Neither of the processes I have found (one here on the FreePBX web site and the other on the FOP 2 web site) have worked.

So what I’m asking for is guidance for updating my distro install from FOP 1 to FOP 2.

I would prefer to go with whatever will eventually end up in the distro because I don’t want to diverge from that if at all possible. So installing the RPM (as mentioned by Tony lewis) should be the best option, but it is supposed to “replace FOP 1” - but it didn’t do that, I am still left with FOP 1. So what do I need to do to fix this?

BTW I already installed the patch mentioned by @Firstsip, and that worked too, but my admin console is not even displaying the FOP server, so again it had absolutely no effect.