FollowMe Time Based + User control

Hello all,

Disclaimer; I’m new to the calendar module.

We want to have followme ring an external number only after hours, so we created a local calendar with a single event that has the business hours which is reoccurring daily, we enabled followme, linked that local calendar and set Calendar Match Inverse to “No”.
It works fine.

But we want to allow that user during business hours to enable followme (Previously they would dial *21EXT.)

But apparently when using the calendar feature, followme is always enabled and if you call the feature code it’ll disable followme completely.

Any ideas?


Toggle the Time Condition not FollowMe since the Time Condition is controlling it.


Which time condition? There’s no time condition involved here. It’s only calendar with follow me.


Because that’s what Calendars are. Snippet from Wiki

You can then use this calendar functionality to enable time conditions, schedule automatic pages, enable/disable find me follow me base on a schedule and more. Over time more of your PBX modules will be able to utilize the Calendar Module to perform date/time base actions.

However, they are done a little differently it would seem that normal TC’s. They use an AGI script to deal with the conditions if enabled so the dialplan looks there first.

What I said earlier still stands, you need to be able to toggle the condition which in this case is the Calendar via a feature code which I’m not really sure right now the best method for doing that is.

In other words, there’s currently no such a feature in FreePBX. And you cannot toggle a Calendar with a Feature Code…

Which brings back my initial question if anyone has any idea how to accomplish that?


I think there can be a way, it will require some custom dialplan. I’m just still trying to figure out the logic so it isn’t that complicated to do or maintain.

Possibly, instead of Follow-Me, route the No Answer destination to a Time Condition in Calendar Mode that selects between a Misc Destination and voicemail. The Time Condition can be overridden with a feature code / BLF key.

Personally, I have Follow-Me always enabled, with sufficient delay such that if the office phone is answered reasonably quickly, the mobile doesn’t ring. Occasionally I’ll get a false missed call on the mobile, not a major hassle. The system is smart enough that if I’m on the phone or in Do Not Disturb, the mobile won’t be rung.

There’s two issues here.

  1. It will be a long wait time for the caller.
  2. You can’t answer the call on the deskphone while it will ring on the cellphone.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.