FollowMe does not work if call comes from Trunk

Hi everybody,
I have an Extension (204) with an active FollowMe configured with an external number.

If I call 204 from an internal extension, freepbx correctly forwards the call to the external number, through the main Trunk.

If I call 204 from an external number through the main Trunk, freepbx doesn’t forward the call to the external number through the main Trunk.

Notice:

  • Our main Trunk supports 3 concurrent calls. Verified.
  • We used different external numbers in our tests: the calling external number was different from the followme external number ti be called.
  • If we call from an external number another extension (say 205) and then 205 forwards the call to 204, Freepbx correctly forwards the call from 204 to the external number configured in FollowMe section.

Any hint?
Thanks in advance.

Hi

Are you calling from A server to server B via trunk as internal calls ?.

Try to add # after follow me number and try it.

Thanks for your hint. We already added the # after the external number to be called.
Everything’s fine if we just call the Extension from another internal extension (the call if forwarded to the external number).
If, instead, the call comes from outside (through the trunk), the system doesn’t forward the call to the external number configured in FollowMe.

Do you have outbound Called ID setup in Trunk. Use Block Foreign CID option in trunk and try again.

1 Like

Call your provider and make sure their CallerID passing rules match your expectation. Inbound calls forwarded from the system normally have the Caller ID of the original caller, and if your provider has a problem with that, the calls will fail.

1 Like

Thanks again.
I tried switching from “Allow any CID” to “Block Foreign CIDs” on the trunk.
Unfortunately, this didn’t solve the problem.

Giving a look at the system logs, I find at some point this (real number was hidden with ‘x’):
app_dial.c: Local/[email protected];1 is circuit-busy

error circuit-busy comes when there are not dial pattern configured properly.

2 Likes

Many many thanks. That solved the issue.
We had some restrictions configured in our Dial Pattern, in the CallerID field.
Now I added a rule, inserting in the CalledID field something accepting the external calling numbers, and everything is working.
I will now look for a way to restrict that rule, so that it is triggered only on FollowMe cases.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.