FollowMe Call Confirm not working?

Hey guys, I’m having a weird issue. We’re running FreePBX 13 (planning to upgrade to 14 eventually, but it’s a bear with Hyper-V) and use FollowMe with call confirm extensively. This has worked fine in the past, where every now and again when we hit 1 to confirm the call it doesn’t take it. However, starting today every single time when we hit 1 the PBX just ignores it. I saw there was issue 18728 which seems to describe my exact issue, I installed the relevant update, no dice. Here’s an excerpt from the log when it’s trying to forward to my cell:

Local/<MYCELL#>@from-internal-0000000f;1 answered Local/RG-601*-<MYCELL#>#@from-internal-0000000e;2

– Executing [[email protected]onfirm:1] Set(“Local/<MYCELL#>@from-internal-0000000f;1”, “LOOPCOUNT=0") in new stack

– Executing [[email protected]:2] Set(“Local/<MYCELL#>@from-internal-0000000f;1”, “__MACRO_RESULT=ABORT”) in new stack

– Executing [[email protected]:3] Set(“Local/<MYCELL#>@from-internal-0000000f;1”, “MSG1=incoming-call-1-accept-2-decline”) in new stack

– Executing [[email protected]:4] BackGround(“Local/<MYCELL#>@from-internal-0000000f;1”, “incoming-call-1-accept-2-decline,m,en,macro-confirm”) in new stack

– <Local/<MYCELL#>@from-internal-0000000f;1> Playing ‘incoming-call-1-accept-2-decline.slin’ (language ‘en’)

– Channel SIP/VP-SIPJFKA-00000005 joined ‘simple_bridge’ basic-bridge <54f52b9e-d772-4b87-a573-d881f07701a0>

– Channel Local/<MYCELL#>@from-internal-0000000f;2 joined ‘simple_bridge’ basic-bridge <54f52b9e-d772-4b87-a573-d881f07701a0>

> 0x7f37d018d180 – Strict RTP switching to RTP target address 52.45.28.115:19960 as source

[2019-01-04 14:27:48] WARNING[2667]: chan_sip.c:4127 retrans_pkt: Timeout on CqvHElmTh6bLuWMY.Call on non-critical invite transaction.

[2019-01-04 14:27:48] WARNING[2667]: chan_sip.c:4127 retrans_pkt: Timeout on CqvHElmTh6bLuWMY.Call on non-critical invite transaction.

> 0x7f37d018d180 – Strict RTP learning complete - Locking on source address 52.45.28.115:19960

– Executing [[email protected]:5] Read(“Local/<MYCELL#>@from-internal-0000000f;1”, “INPUT,1,4") in new stack

– Accepting a maximum of 1 digits.

– User entered nothing.

– Executing [[email protected]:6] GotoIf(“Local/<MYCELL#>@from-internal-0000000f;1”, “0?,1:t,1") in new stack

I have confirmed that outbound calls work fine with audio both directions, so I don’t think it’s an RTP issue of the PBX not “hearing” the keypress. I have also rebuilt asterisk to the latest version of 13 (13.23 I think?). I’ve installed installed every module update available, no dice. There were no changes made to our PBX around the time this issue started, AFAIK.

Thanks for your time!

Hey guys, I upgraded our install to 14 using the conversion tool, and I’m still having this issue. Can anyone please provide any insight?

Does DTMF work fine in your IVR’s?

Can you post your Trunk config?

Yes it does.

Trunk config:
username=
type=peer
trustrpid=yes
secret=
rfc2833compensate=yes
qualify=5000
insecure=port,invite
host=jfk-primary.voicepulse.com
dtmfmode=rfc2833
disallow=all
context=from-pstn
canreinvite=no
allow=ulaw

What is this for? I never used it.

Honestly, I have no idea. That’s just what the documentation from our SIP provider (Voicepulse) tells me to do.

EDIT: based on here: https://issues.freepbx.org/browse/FREEPBX-2724

It looks like it’s a compatibility flag for dealing with older Asterisk versions… I tried removing it and it doesn’t make any difference.

NEXT DAY EDIT:
Well… the problem went away on its own overnight, just like it showed up. I think I’m going to blame this one on the SIP provider and not our FreePBX.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.