Follow Me ringallv2 behaviour

It seems as though the ringallv2 strategy is behaving the same as the ringall strategy. From what I’ve read, ringallv2 should initial a call to the primary extension and then after the initial ring time, without terminating the call to primary extension, inititate call to other extensions in the follow-me list.

So my configuration is as follows:
FreePBX: 13.0.188.8
Asterisk: 13.11.2

Looking at the log file, it seems to execute a hangup after 7s (initial call duration) and the initiates the new call to the follow me list. Wondering if there’s something I’ve got configured wrong.

[2016-10-18 09:22:25] VERBOSE[18190][C-00001527] res_agi.c: dialparties.agi: Starting New Dialparties.agi
[2016-10-18 09:22:25] VERBOSE[18190][C-00001527] res_agi.c: dialparties.agi: Caller ID name is ‘Primary Reception’ number is ‘260’
[2016-10-18 09:22:25] VERBOSE[18190][C-00001527] res_agi.c: dialparties.agi: Methodology of ring is 'ringallv2’
[2016-10-18 09:22:25] VERBOSE[18190][C-00001527] res_agi.c: dialparties.agi: Added extension 303 to extension map
[2016-10-18 09:22:25] VERBOSE[18190][C-00001527] res_agi.c: dialparties.agi: Extension 302 cf is disabled
[2016-10-18 09:22:25] VERBOSE[18190][C-00001527] res_agi.c: dialparties.agi: Extension 303 cf is disabled
[2016-10-18 09:22:25] VERBOSE[18190][C-00001527] res_agi.c: dialparties.agi: Extension 302 do not disturb is disabled
[2016-10-18 09:22:25] VERBOSE[18190][C-00001527] res_agi.c: dialparties.agi: Extension 303 do not disturb is disabled
[2016-10-18 09:22:25] VERBOSE[18190][C-00001527] res_agi.c: dialparties.agi: Discovered PJSIP Endpoint PJSIP/302

[2016-10-18 09:22:25] VERBOSE[18192][C-00001527] app_dial.c: Called PJSIP/302/sip:[email protected]:5060
[2016-10-18 09:22:25] VERBOSE[18190][C-00001527] app_dial.c: Local/[email protected];1 is ringing
[2016-10-18 09:22:25] VERBOSE[18190][C-00001527] app_dial.c: Connected line update to PJSIP/260-0000270f prevented.
[2016-10-18 09:22:25] VERBOSE[18192][C-00001527] app_dial.c: PJSIP/302-00002710 is ringing
[2016-10-18 09:22:25] VERBOSE[18190][C-00001527] app_dial.c: Local/[email protected];1 is ringing

[2016-10-18 09:22:32] VERBOSE[18193][C-00001527] res_agi.c: Launched AGI Script /var/lib/asterisk/agi-bin/dialparties.agi
[2016-10-18 09:22:32] VERBOSE[18192][C-00001527] app_dial.c: Nobody picked up in 7000 ms

[2016-10-18 09:22:32] VERBOSE[18192][C-00001527] app_macro.c: Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘Local/[email protected];2’ in macro 'hangupcall’
[2016-10-18 09:22:32] VERBOSE[18192][C-00001527] pbx.c: Spawn extension (from-internal, h, 1) exited non-zero on ‘Local/[email protected];2’
[2016-10-18 09:22:32] VERBOSE[18193][C-00001527] res_agi.c: dialparties.agi: Starting New Dialparties.agi
[2016-10-18 09:22:32] VERBOSE[18193][C-00001527] res_agi.c: dialparties.agi: Caller ID name is ‘Primary Reception’ number is ‘260’
[2016-10-18 09:22:32] VERBOSE[18193][C-00001527] res_agi.c: dialparties.agi: Methodology of ring is 'ringall’
[2016-10-18 09:22:32] VERBOSE[18193][C-00001527] res_agi.c: dialparties.agi: Added extension 303 to extension map
[2016-10-18 09:22:32] VERBOSE[18193][C-00001527] res_agi.c: dialparties.agi: Extension 303 cf is disabled
[2016-10-18 09:22:32] VERBOSE[18193][C-00001527] res_agi.c: dialparties.agi: Extension 303 do not disturb is disabled
[2016-10-18 09:22:32] VERBOSE[18193][C-00001527] res_agi.c: dialparties.agi: Discovered PJSIP Endpoint PJSIP/303
[2016-10-18 09:22:32] VERBOSE[18193][C-00001527] res_agi.c: dialparties.agi: Ended up with real PJSIP Dial string PJSIP/303/sip:[email protected]:5060
[2016-10-18 09:22:32] VERBOSE[18193][C-00001527] res_agi.c: dialparties.agi: dbset CALLTRACE/303 to 260
[2016-10-18 09:22:32] VERBOSE[18193][C-00001527] res_agi.c: dialparties.agi: Filtered ARG3: 303
[2016-10-18 09:22:32] VERBOSE[18193][C-00001527] res_agi.c: <Local/[email protected];2>AGI Script dialparties.agi completed, returning 0

looks to me like it dialed ext 302, and then after 7 seconds it also dialed 303 - so what do you think is not working?

ring strategy is set to ringallv2, but ext 302 stops ringing after 7s, it should continue to ring. I might not understand the log files correctly but it appears as though the line after it says “nobody picked up” indicates it hung up the call to ext 302, which is not the correct behaviour.

is 302 listed in the fmfm list?

No, but according to Ring Group and Follow-Me Ring Strategies (2 of 2) as I’m using “ringallv2” it doesn’t need to be? Unless I’ve completely misunderstood how to configure FM/FM.

The ringallv2 strategy is about changing these subtle, but annoying, behaviors. In this strategy, FreePBX® forks two “threads” of control. The first rings your primary extension while the second thread sleeps for a while (the Initial Ring time). If you haven’t answered within that time, the second thread kicks in and starts to ring the other phones (while the first thread continues ringing your primary extension – thus no more hang-up or double missed calls).

did you happen to notice the date on that post? there are people on this board that were not even born when it was posted. stick 302 in the list as the first phone on the list and see what happens

1 Like

Yes, putting the extension itself in the follow-me list does solve the problem, just seems at odds with the way the documentation is worded. Description from the GUI:

ringallv2: ring Extension for duration set in Initial Ring Time, and then, while continuing call to extension, ring Follow-Me List for duration set in Ring Time.

It doesn’t indicate at all that the extension itself should be also listed in the follow-me list, as it states that it will continue to call the extension, as well as the follow-me list.

by default the extension is always added to the list so you must have deleted it.

I just confirmed this on a fully up to date 13 system, ringallv2 behaves the same as ringall. @tlarrea, did you file a bug at issues.freepbx.org?

Problem: dial application for the prime extension in a group with strategy ringallv2 has a dial timeout set to Initial Ring Time, and it should be (Initial Ring Time) + (Ring Time)

Hi Lorne,

no I didn’t file a bug as I wasn’t sure it was actually a bug yet. I can go ahead and submit it if you like?

@lgaetz I’ve gone ahead and logged a ticket for this with description as per your post.

1 Like

This seems to be as intended. In the debug of the dialplan you’ll notice this message:

dialparties.agi: extension not in group list, ringing only during prering time

This line has been around since at the latest 2009. ( https://github.com/FreePBX/core/commit/5be94b7679b5ce1e0a0b8582e5cc6b8dff251341 )

I didn’t go back further and look.