Follow-Me - Message

I am trying to implement the follow-me feature. For some reason I am not able to get the system to playback my voicemail message if no one picks up. Callers get system message to record a message not message that was recorded for voice-mail box.

For reference purposes, I am selecting my extension number’s voice-mail box as destination if no one picks up.

If I disable follow-me function on that extension voice-mail message is plaid for caller.

Any suggestions?

Also, may I suggest in the follow-me page where users can input the ring list, that the help window should go into a little more detail by indicating that you must include the extension number for the extension linked to the follow-me function. For example, if I select follow-me option from extension 210. If I want it to ring 210 and 211 that I must put both in the list. The reason for this comment is that I assumed, as I suspect many would, that I did not have to list 210 in ring list attached to 210.

Further the comment relates to “#”, it would be helpful if help message indicated all outgoing calls not cell phone calls.





Great answer, I normally am that way and that is how I have learned most of what I know about this project. That and reading everything I can find.

Hope Rob find’s a place to put a helpful popup on this suject. Also I will be forwarding this thread to some of the online documents to see if they will add it to thier work.




To be brutally honest, a complex working mixture of ADD and OCD. :wink:

When I turned on FollowMe to get around our queue transfer problem, users immediately complained that their own voices were no longer on their voicemail. I am an ‘experimental’ problem solver…I typically just start pushing buttons and pulling levers rather than trying to reason out the problem…and that’s what I did. There aren’t many places in FreePBX to specify vm destinations, so I played with them until it worked

Looking at it in reverse, I probably could have figured out how the FollowMe transfer to vm was being performed from watching CLI and it would have been obvious. But the ADD kicked in and told me, “Push this button! Now push that button! Hey, look, that guy’s wearing a yellow shirt!” and I had the answer…

In your general settings, change the Direct Dial to Voicemail Type to ‘unavailable’.

Thanks a lot. It worked like a charm.

Just wondering though? How is someone to know that? I have working with FreePBX since July and I do not remember reading anything about this or the use of the setting in General Settings. I may have missed it but for all those that have similar questions in future, would it be worth adding some sort of quick documentation on that issue in either/both spots about how this works. Also, in the general settings, there is an option for unavailable and for busy but not both. Should there be a both option, or does one already include the other by definition?

Thanks again.