Flowroute PJSIP Trunk Inbound Not Working


(RPG) #1

We are transitioning from Chan_SIP to PJSIP and we use Flowroute as the SIP provider.
All our extensions are PJSIP (converted from Chan_SIP)
Added PJSIP Trunk based on the recommended settings from Flowroute https://support.flowroute.com/895670-FreePBX-PJSIP-Trunk-Setup
We use port 5060 for PJSIP and 5160 for Chan_SIP
Outbound calls work fine but I can’t get the inbound calls to work. When I make an inbound call, I get the message “The number you have dialed is not in service”. We have all the Flowroute’s IP addresses (147.75.60.160/28,34.210.91.112/28,34.226.36.32/28,147.75.65.192/28) in the intrusion detection whitelist and in our router’s firewall exception.
I also tried recommendations from this post: HOW TO - Flowroute Trunk with Proper Use of IP Auth and new PoPs

If I disable our Flowroute PJSIP trunk and enable the Flowroute Chan_SIP trunk then all inbound calls work just fine with all PJSIP extensions. So this tells me that there may be a setting in the PJSIP trunk that I am just missing but I just can’t figure which one. The settings are all correct per Flowroute’s recommendations. I want to see if I can get any help from someone who got everything working and maybe tell me if there is something I am missing. Any help is appreciated.

Here is a screenshot of the PJSIP trunk settings.






image

Asterisk SIP Settings:


#2

Your logs are the best source of information on why it is failing.


(Luke C) #3

I seen a post the other day about if you are using 5060 on your PJSIP Trunk(which FR says you must do), then you have to change the “Asterisk Sip Settings” PJSIP to an alternative port, if I recall correctly.


(Dave Burgess) #4

The thing that puzzles me is if you use the Chan-SIP port (which you say is 5160), the FlowRoute traffic is processed, but if you use the PJ-SIP port (which you say is 5060), the traffic doesn’t flow. If that’s true, double check your port configurations in the PBX and at FlowRoute. Make sure you are using port 5060 for everything (since you want to use PJ-SIP).

Also, make sure that FlowRoute is using user-auth and not IP Authentication. We’ve been talking out the FlowRoute POP fiasco for a couple of weeks now, and IIRC, one of the changes is that they’re using IP Authentication instead of User Authentication.


(RPG) #5

I have 5060 for PJSIP and 5160 for Chan_SIP in the Asterisk SIP Settings. I have 5060 set in my Flowroute settings for inbound and my DID is linked to that route. Am I missing any other settings? This is why find it puzzling as well.


(RPG) #6

Is this a setting in Flowroute or PBX?


(Luke C) #7

(RPG) #8

Same thing. I get 401 back error for inbound calls. For mine though, I don’t have Chan_SIP and PJSIP enabled at the same time. They don’t share ports. 5160 is for Chan_SIP and 5060 for PJSIP. I disabled my Chan_SIP trunk. I have PJSIP trunk only and all my extensions are PJSIP. I have all Flowroute’s New POP IP addresses in the match(permit) in the PJSIP trunk–>Advanced Settings. Do you mind sharing a screenshot of your PJSIP trunk settings? Removing sensitive data from it of course. I am pretty sure there is just one setting in the PJSIP trunk that I am missing because if I disable my PJSIP trunk and enable the Chan_SIP trunk, inbound works fine. I am also heading towards that my issue could be the match(permit) setting in the PJSIP (https://issues.freepbx.org/browse/FREEPBX-17109) but I am not sure what would be the workaround. That 401 error tells me that my Freepbx is denying the traffic coming from Flowroute’s IP addresses.


(Luke C) #9

This is all I used, https://support.flowroute.com/895670-FreePBX-PJSIP-Trunk-Setup

In my previous reply, the user stated that flowroute had them change their listen port under “asterisk sip settings” to something other then 5060 for PJSIP, but they still used 5060 on their trunk connection to FR.