FlowRoute inbound connection always rejected

I’m new to FreePBX but have been fiddling with this for days.

I’ve got my two extensions working fine on Cisco 7961 IP phones.
I’ve got my outbound trunk through FlowRoute working fine.
My inbound from FlowRoute always gets rejected with this log entry:

NOTICE[2606][C-00000001] chan_sip.c: Call from ‘YYYYYYYY’ ( to extension ‘XXXXXXXXXXX’ rejected because extension not found in context ‘inbound’.

I’ve created an inbound route for this DID.
I keep seeing documentation that says to add an extenstion into the [inbound] context in sip.conf, but I don’t have this. I added it, but it didn’t work.

I know you guys normally ask which version I’m using, and I’m not exactly sure. I did download this one though:
Release Date-01-25-13
FreePBX 2.11, Linux 6.5
Asterisk 1.8 or 11

I’ve tried everything I could find. I researched this a lot!

The main problem with flowroute is that they have multiple IP addresses attached to their srv record. This is quite normal in terms of some SIP providers, however Asterisk itself has never handled this well and therefore will only allow incoming calls from whatever single IP address it has determined is the master for that record. This is solved in Asterisk 12, however for you, you’d need to come up with a list of the IP addresses flowroute uses for SIP Signaling and create a trunk for each one.

Thanks for the reply. That makes sense.

Question: In my only trunk, used for outbound calls through FlowRoute, where would I put the IP addresses I’ve obtained from FlowRoutes SRV records when I create a new trunk. In other words, what would the settings of my new trunk look like for IP address

you would do: host=

note: trunks are used for outbound and inbound calls.

sorry continuing on, but I’m not clear what the remaining fields would be.

Walk me through these steps:

  1. Add new SIP trunk?
  2. Give it a trunk name
  3. Fill in Incoming Settings > USER context? If so, with what?
  4. Fill in Incoming Settings > USER details with host=?
  5. Save?

Flowroute will need to provide you the details. It is different for every provider.

Also you need to read the section on trunks in our wiki and check out the sample Asterisk sip.conf page, it explains all the trunk variables.

Don’t ever just blindly enter stuff in the trunk.

Also flowroute won’t give you FreePBX specific instructions you must leave out the context header if they give one and assign the peer to the from-trunk context.

After spending almost an hour on the phone with a sweet gal from FlowRoute, we’ve solved the problem.

Simply delete the FlowRoute SIP trunk, inbound route, and outbound route. Reboot. Recreate them with the exact same settings.

A tcpdump on the PBX revealed the server was replying with a 404 not found. We knew that simply wasn’t true. It had nothing to do with adding specific IP addresses. As a matter of fact, Asterisk 11 seems to handle it just fine without any modifications to the basic info which FlowRoute provides on their website for FreePBX configuration.

Thanks, FlowRoute!