[FIXED] Unanswered transferred calls not going to voicemail

Scenario: External caller is answered by receptionist who then transfers the caller to extension 201. Extension 201 will ring forever with VM never picking up. If receptionist calls 201 and no one answers it goes to voicemail. If external caller calls the DID of extension 201 they get voicemail after it rings for a bit. Why does the VM not respond for a transferred call? Thanks

I’m having the same problem. I’m running 6.12.65-28 Asterisk ver. 11.18.0 on the x64 centos.

VM does eventually pick up after about 2 min. All ring times are set to default, and I’ve even tried setting them to 5 with no change.

This is second-hand information, but apparently enabling Follow Me on each of the extensions seems to fix the problem. This is a workaround, however.

Good to know. That worked for now.

Yep we are seeing the same thing at my work as well.

Ok so this workaround cleared up the endless ringing, but it broke the intercom. All the extensions are set to internal auto answer, but with the follow me active, the extensions ring instead of intercom.

Do the devs know about this bug, I can’t find it in the bug tracker?

http://issues.freepbx.org/browse/FREEPBX-9728

I am in the same office as mvogel. I started another thread, but this one has picked up. Here is what we found yesterday:

System is a OEM Distro up to date. Asterisk Version 11.18, PBX is at 6.12.65-28

We spent some more time at this customers office this morning. It appears that a call that is originally answered from a Ring Group call is affected. All direct ring in DID calls and direct ring in DID calls that are transferred work. Calls from one phone to another also work. Here are my notes:

Called the main number that rang into a Ring Group. Ext 225 transferred the call to 221. Call rang until I hung up at 2 minutes:
Line from the Reports/Asterisk Info/Connections
SIP/ClearRateSIP-000 [email protected]:44 Up Dial(SIP/221,TtrM(auto-blkvm)

Called a DID that rang into ext 225 and was transferred to 221, after 10 seconds I got the unavailable voicemail.
Line from the Reports/Asterisk Info/Connections
SIP/ClearRateSIP-000 [email protected]: Up VoiceMail([email protected],u)

Setting the VoiceMail “No Answer” in the extension to “Voicemail Unavail to the mailbox” That appeared to be a work around.

Did this begin for all of you within the last week or so after updating?
We manage many FPBX servers for customers, and after updates applied last Saturday, all of them started exhibiting this symptom. I believe it may have occurred with Framework 12.0.71 update, but I am not sure. These servers are maintained regularly, so it has to have been an update released within the last two weeks. Saturday’s updates only impacted a small number of modules, and Framework is the only one that makes sense to me, but what do I know. Input appreciated.

Just to clarify. While this could be a bug it would not be in framework. In fact framework 71 was released yesterday and was a fix to an installer bit. It has nothing to do with what you are talking about.

Most likely it would be a bug in core. To which you can rollback all modules. If you believe it’s in issue in something then please use the rollback feature. It helps us out.

Furthermore please provide asterisk logs. No one has done that yet.

Fixed in core v12.0.35 and core v13.0.1beta1.13

Thanks in large part to @dolesec and @lgaetz of our support team whom I derailed for 2 hours today to look into it and get me the details I needed, including helping to pinpoint the code that was causing the issue.

I am getting this same behavior using core v12.0.43.

Works for me. Suggest you start a new thread with a sanitized call trace.

I figured it out, STRREPLACE is not valid on Asterisk v1.8

1 Like

So does this mean that it cannot be fixed? I am having the same issue.

Internal call goes into Queue.
Call is answered, then blind or attended transferred to another internal extension
The call never goes to voicemail, and the original caller doesnt hear ringing during that time. Only silence. Then after about 1 minute, the call disconnects.

This issue is still happening with the latest version of Asterisk. Is anyone else having this issue?

The transferred call rings for about 20 rings and then disconnects the call. The caller hears silence during this time instead of hold music.

Lucas, The issue we were having was fixed. It had to do with a prior update that broke it. If you’re having a similar issue it’s unrelated.

Is this a new system on an existing system? Did it ever work?

Yes, it is a newer system, but it was working in the past. It worked, then after a few weeks, it stopped working. Updating the system and all modules didn’t fix it. Then I rebooted the server, and it started working again. Then after about another week, it stopped working again. I doubt it has anything to do with the specific phones being used (Yealink W52P phones), but at this point, I’m open to any ideas.

Thanks!