Firewall Trouble

I’ve been having trouble with the System Firewall. Putting eth0 into the External zone cuts off all access, forcing me to stop the firewall to reconnect to the GUI.


1469559553: Unparseable output from getservices - [“Exception: Protocol ‘udp’ didn’t tell me what port it was listening on in file /var/www/html/admin/modules/firewall/Smart.class.php on line 185”,“Stack trace:”," 1. Exception->() /var/www/html/admin/modules/firewall/Smart.class.php:185"," 2. FreePBX\modules\Firewall\Smart->getSipPorts() /var/www/html/admin/modules/firewall/Smart.class.php:75"," 3. FreePBX\modules\Firewall\Smart->getVoipPorts() /var/www/html/admin/modules/firewall/Smart.class.php:65"," 4. FreePBX\modules\Firewall\Smart->getAllPorts() /var/www/html/admin/modules/firewall/Firewall.class.php:900"," 5. FreePBX\modules\Firewall->getSmartPorts() /var/www/html/admin/modules/firewall/bin/getservices:22"] - returned 1
1469559553: Unable to see safemode in services… Sleeping 5 seconds and retrying

I’ve tried removing the firewall module completely and downloading it again. Rerunning the setup wizard. As far as I can tell, everything is configured properly. Can anyone point me in the right direction to resolve this?

PBX Firmware: 10.13.66-13

dumb question - do you have your ip address listed as a trusted ip in the zones->network settings?

Yes. My local IP and subnet are set to Trusted

More info that I should’ve added to the OP, when I set eth0 into the external zone, trunks and endpoints go down as well. It’s not just SSH/GUI access.

do you have ipv6 enabled on your system?

No ipv6.

Nevermind. It looks like another tech was in mucking with the UDP settings under Advanced SIP Settings. They were reset to default and all is well. Thanks for your time.

1 Like