Firewall (services) error after updating firewall and framework

So i had a framework update and firewall update and all went fine.

BUT after updating if i go to :

Firewall >> right menu >> services

i get this :

i tried to forceinstall the framework again and firewall but still the same.

Hi @DRF Please try with the latest firewall module.

If on Freepbx 15 -
fwconsole ma downloadinstall firewall --tag=15.0.31

If on Freepbx 16 -
fwconsole ma downloadinstall firewall --tag=16.0.44


i get :

unable to update module firewall 15.0.31 does not exist

Did you tried below command or checking via module update UI page ?
fwconsole ma downloadinstall firewall --tag=15.0.31

If its showing not available then please check your MODULE_REPO settings i.e.

`fwconsole setting MODULE_REPO
Setting of “MODULE_REPO” is (text)[]

If all above is good and you are not getting 15.0.31 version then please share the output of cat /etc/sangoma/pbx-brand


Thank you so much

i forgot that i changed to clearlyip mirror for their softphone module.
so that was the reason it could not find it.

now it is reinstalled and working (Y)

question, so i updated the firewall with the wrong mirror and thats why it failed in the first place?

It’s a legit bug with an update to resolve in firewall versions 15.0.31 and 16.0.44. This version was only published to the official FreePBX mirrors a few hours ago, so presumably there is a lag for unsupported repos to catch up.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.