Firewall Integrity Failed

Hello dear community,

Need some clues on the following problem:
Have an installation of the freepbx server according to the guide at
All is fine but the firewall reports an error upon boot: "Firewall Integrity Failed (Interface eth0 is not in the correct zone…)"
If I set eth0 as external in the settings the system kicks me out, loosing connection to it, only thing possible is to perform a reboot.
However if I run fwconsole firewall start after the reboot - firewall rules applied correctly, dashboard reports no issue, eth0 becomes correctly marked as external in the web-interface.
Reproduced the problem on another virtual server on virtualbox, so its not accidental misconfiguration.

Found some similar discussions here, most of them are solved with updating firewall module, but it is of latest version (
If I use the same firewall module version on the system that was installed form the image - then everything works perfectly, firewall starts upon reboot with no issues.
So need some directions where to dig - couldn’t find the root cause of the problem.

System Firewall module: