Firewall integrity failed

The FreePBX dashboard gives me the following error: Interface eth0 is not in the correct zone. This can be caused by manual alterations of iptables, or, an unexpected error. Please restart the firewall service.

examining the firewall i see that eth0 is in the trusted zone which as i have read is incorrect so i move it to the external zone. once i do that i am locked out of the web gui and have to restart the machine to get it back. since I’m not able to click the apply config button after changing the zone config the server comes back up and i’m able to access the web gui but eth0 is back in the trusted zone.

im running freepbx with the firewall module at

I’ve tried disabling and reenabling the firewall module a few times but can’t get this problem to go away. does anyone have any idea what might be happening here?

The current version of Firewall is – please upgrade to that.

Just as a point of reference this is a problem i’ve been having for the better part of 6 months through multiple iterations of the firewall module. every time I’ve update the firewall I’ve tried removing and reinstalling it.

I just tried updating the firewall but the repo reports as the latest.

It looks like there’s a bit of a backlog in QA, you’ll need to enable Edge mode to get that version - you can do it from the command line with fwconsole --edge ma downloadinstall firewall

Excellent! that seems to have taken care of it!

1 Like