Firewall FreePBX perplessità - blocco porta 80


#1

Ciao a tutti,
installando freepbx se non ho compreso male viene abilitato un proprio firewall o comunque prende in gestione numerose politiche.
Ammetto che ancora non ho ben compreso come è strutturato, io sono abituato a lavorare con iptables da linea di comando. Io vorrei interdire l’accesso alla porta 80 da tutti gli IP e lasciarla raggiungibile da un solo IP sicuro. Ma se abilito il firewall di FreePBX le mie regole di iptables vengono totalmente ignorate.

Eseguendo un iptables -L vedo

rejsvc-http all – anywhere anywhere
Chain fpbxsvc-http (0 references)
ACCEPT tcp – anywhere anywhere tcp dpt:http
Chain fpbxsvc-https (1 references)
ACCEPT tcp – anywhere anywhere tcp dpt:https
ACCEPT tcp – anywhere anywhere tcp dpt:radan-http
Chain rejsvc-http (1 references)

Sembrano catene riferite alla gestione del protocollo http, ma accettano tutto.
Chiedo scusa. Ma come posso risolvere questo problema?

Grazie a tutti.


(Danilo Smaldone) #2

Ciao @codabat prendendo spunto da qui: https://wiki.freepbx.org/display/FPG/Firewall+Zones

"Ogni pacchetto che entra nel sistema è etichettato come parte di una Zona e filtrato secondo le regole di quella zona. La classificazione e (ordinamento della classificazione) sono spiegati nella pagina Technical Details.

Il firewall funziona in modalità “Nega per impostazione predefinita” e rimuove la precedente necessità di inserire nella blacklist le reti, poiché sono bloccate per impostazione predefinita.

Alternativa 1: Il mio suggerimento è di associare l’IP/network che vuoi abilitare ad una Zona Other in Firewall>>Networks. Fatto questo vai nel responsive firewall e dichiari la porta 80 è di tipo Other. Importante notare che let’s Encrypt funziona solo sulla porta 80

Alternativa 2: Vai in Firewall / Advanced /Advanced Settings e definisci le Custom Firewall Rules. Richiede un pò più di pratica, ma può funzionare nel tuo caso


#3

Ciao @dsmaldone,
prima di tutto ti rivolgo le mie scuse se ho potuto rispondere al tuo aiuto e alle tue spiegazioni, ma in questi giorni ho avuto un po’ di problemi da affrontare (niente di grave).
Come sempre gentilissimo ed esaustivo. Riprendo il percorso di approfondimento, anche grazie alle indicazioni che mi hai fornito.
Al momento ho creato su iptables una regola che accetta connessioni sulla porta 80 solo esclusivamente da indirizzi noti (miei). Similmente come faccio per la porta 22 accetto connessioni da indirizzi noti (generalmente un solo indirizzo mio noto).
Tuttavia, ti ringrazio, perché ancora non ho e non avevo compreso a pieno le logiche di firewall di FreePBX. Scusami tanto la mia ancora scarsa conoscenza del prodotto e allo stesso tempo davvero grazie per la tua disponibilità.
Ti auguro una serena Pasqua.
Pre-allertandoti che se ci fosse qualcosa (ce ne saranno moltissime sicuramente) tornerò a confidare nella vostra e nella tua disponibiità.
Un carissimo saluto.


(Danilo Smaldone) #4

Ciao @codabat lo scopo del Forum è di condividere e aiutare. Gli Americani dicono “Sharing is caring”
ovvero Condividere è prendersi cura…in questo caso noi facciamo in modo di condividere le informazioni per prenderci cure e imparare l’uno dall’altro!
Segno il post come risolto!
Grazie a te per la gentilezza


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.