Firewall - error on initial setup adding LAN IP to trusted zone

Just did a new test spin of FPBX13-Stable. All went smoothly. After reboot, the console said that all modules were being updated. Success.

Upon login, I was greeted by the barbed wire frog and prompted to enable the Sangoma Smart Firewall. Ok, great did that. Next it asked me if I want to add my LAN IP ( to the trusted zone? I tried to click YES but got a red exception error:

Tried to answer a question that wasn’t asked

I am pausing here now, is this “normal”? Should I just skip?

Few more screenshots…

Pinging @xrobau on this for you.

Ok. In the meantime just in case I did something wrong, I’m going to try to re-download the Fpbx ISO and spin up a fresh one to double check. One thing I did during the Anaconda setup was I elected to “disable IPv6 support” since in my lab network I don’t have working IPv6 connectivity. Could this have affected the script somehow?

That’s a strange one. It’s just part of the integrity checks in Firewall. It’s saying your browser tried to answer a question that wasn’t asked, or, was already answered.

This can happen if you had two browser windows open, or clicked ‘back’ after answering a question. I’ll put some more debugging in there.

To answer your question, it’s fine to continue. Normally just doing a reload (in the browser) will fix it, and you’ll continue on normally.

The 2nd spin I did worked fine! This time I left everything at “defaults” and did not touch any settings during the ncurses setup. Not sure if that was the key or not. I will try a 3rd spin with IPv6 disabled as I did with the 1st one just to confirm.

So I guess maybe this was just a bug in the ‘framework’ module since I noticed that was updated earlier today. The 3rd spin I did, I again disabled IPv6 during anaconda setup and this time I got no errors setting up the Smart Firewall. Onward!