Firewall breaking tftp

I’ve been fighting with tftp server for the last few days, and got it to work when I disabled the firewall. After digging through the rules I noticed the established rule for udp only allows a few ports, and tftp isn’t one of them. I don’t see anywhere in the GUI this can be modified or corrected. How do I get tftp added to, or the port restriction removed from, the udp related established rule?

Chain fpbxfirewall (1 references)
target prot opt source destination
ACCEPT all – anywhere anywhere
ACCEPT tcp – anywhere anywhere state RELATED,ESTABLISHED
ACCEPT udp – anywhere anywhere udp spts:tcpmux:1024 state RELATED,ESTABLISHED

You enable it in Firewall Extra Services

Yes, It is enabled in extra services, the fpbxfirewall chain is where it is being blocked, not the zone chains.

and is the ip address of the phone or whatever is trying to tftp from the pbx also listed in the trusted zone?

No, It’s an external IP, which is selected as shown above.

you must still add the external ip address to the trusted zone. simply setting the firewall to say the service is external is not enough.