Findmefollowme page blank

I’m running freepbx framework on freepbx distro.

I clicked submit changes in the findmefollowme module and now SERVERIP/admin/config.php?display=findmefollow is now blank
amportal a ma list
findmefollow 12.0.11 Enabled

If I uninstall the module, then reinstall it, I can get to it. But once I try to reconfigure an extension with followme, the page becomes blank again as soon as I click the “submit changes” again.
/admin/config.php is still accessible.

I’ve also tried removing the followme module and re-downloading it and installing, but I’m still getting the same problem

I have a separate problem with sysadmin module and oobe, but that’s currently not installed at all at the moment.

I uploaded 12.0.10 from github. Nevermind the unsigned modules warning, at least it’s working!

Once I ran
amportal a ma refreshsignatures
amportal a reload

…find me follow me no longer works.

Module              Version           Status
------------------- ----------------- -------------------
accountcodepreserve          Enabled
announcement          Enabled
areminder                             Not Installed (Locally available)
arimanager          12.0.3            Enabled
asterisk-cli          Enabled
asteriskinfo        12.0.2            Enabled
backup              12.0.19           Enabled
blacklist           12.0.3            Enabled
bria                12.0.11           Enabled
broadcast                             Not Installed (Locally available)
builtin                               Enabled
bulkdids            Enabled
bulkextensions          Enabled
callback                              Not Installed (Locally available)
callerid                              Not Installed (Locally available)
callforward         12.0.7            Enabled
calllimit                             Not Installed (Locally available)
callrecording       12.0.4            Enabled
callwaiting         12.0.3            Enabled
campon              Enabled
cdr                 12.0.23           Enabled
certman             12.0.6            Enabled
cidlookup          Enabled
conferences         12.0.20           Enabled
conferencespro                        Not Installed (Locally available)
contactmanager      12.0.5            Enabled
core                12.0.39           Enabled
cos                                   Not Installed (Locally available)
customappsreg          Enabled
dahdiconfig         2.11.52           Enabled
dashboard           12.0.32           Enabled
daynight            Enabled
dictate             Enabled
digium_phones          Enabled
directory           12.0.2            Enabled
disa                12.0.2            Enabled
donotdisturb        12.0.3            Enabled
endpoint                              Not Installed (Locally available)
extensionroutes                       Not Installed (Locally available)
fax                 12.0.9            Enabled
faxpro                                Not Installed (Locally available)
featurecodeadmin    12.0.2            Enabled
findmefollow        12.0.11           Enabled
framework          Enabled
freepbx_ha                            Not Installed (Locally available)
fw_ari              12.0.7            Disabled
fw_langpacks        12.0.7            Enabled
hotelwakeup         2.11.3            Enabled
iaxsettings          Enabled
infoservices          Enabled
irc                 Enabled
ivr                Enabled
javassh             2.11.2            Enabled
languages           Enabled
logfiles            12.0.6            Enabled
manager             12.0.2            Enabled
miscapps            Enabled
miscdests           Enabled
music               12.0.1            Enabled
outroutemsg          Enabled
paging              12.0.14           Enabled
pagingpro                             Not Installed (Locally available)
parking            Enabled
parkpro                               Not Installed (Locally available)
pbdirectory          Enabled
phonebook           Enabled
phpinfo             Enabled
pinsets             Enabled
pinsetspro                            Not Installed (Locally available)
presencestate       12.0.30           Enabled
printextensions          Enabled
queueprio           Enabled
queues              12.0.20           Enabled
qxact_reports                         Not Installed (Locally available)
recording_report                      Not Installed (Locally available)
recordings          12.0.8            Enabled
restapi                               Not Installed (Locally available)
restapps                              Not Installed (Locally available)
restart             12.0.1            Enabled
ringgroups          Enabled
setcid              Enabled
sipsettings         12.0.16           Enabled
sipstation          Enabled
sms                 12.0.19           Enabled
sng_mcu             Enabled
speeddial           Enabled
superfecta          2.11.17           Enabled
sysadmin           Enabled
timeconditions      12.0.8            Enabled
tts                Enabled
ttsengines          Enabled
ucp                 12.0.24           Enabled
ucpnode                               Not Installed (Locally available)
userman             12.0.27           Enabled
versionupgrade      12.0.1RC1.0       Enabled
vmblast             12.0.1            Enabled
vmnotify                              Not Installed (Locally available)
voicemail           12.0.43           Enabled
voicemail_report                      Not Installed (Locally available)
vqplus                                Not Installed (Locally available)
weakpasswords       12.0.3            Enabled
webcallback                           Not Installed (Locally available)
webrtc              12.0.3            Enabled
xmpp                                  Not Installed (Locally available)

it sounds like you have some bad data somewhere

run amportal a ma dbug in your console then try loading the page.

I’m getting a list of parameters to use with that comand:

    # amportal a ma dbug

Fetching FreePBX settings with gen_amp_conf.php..

  /var/lib/asterisk/bin/module_admin [params] <operation> <module> [parameters.. ]
  -f  Force operation (skips dependency and status checks)
      WARNING: Use at your own risk, modules have dependencies for a reason!
  -R, --repo, --repos repo1,repo2,repo3...)
      List of repositories to check, valid options: extended,standard,commercial,unsupported)
      Locally installed modules will be checked despite the repository list.)
  checkdepends <module>
      Check if module meets all dependencies
  delete <module>
      Disable, uninstall, and delete the specified module
      Disable, uninstall, and delete ALL MODULES
      WARNING: Use at your own risk, this will remove ALL MODULES from your system!
  disable <module>
      Disable the specified module
  download <module>
      Download the module from the website
      If -f is used, downloads even if there is already a copy.
  enable <module>
      Enable the specified module
  info <module>
      Get information about a given module
  i18n <module>
      print out i18n required text for the given module
  install <module>
      Install the module (must exist in the modules directory)
      Installs any module not installed that is locally available
      Installs all module that exist in the repository
      ReDownloads all modules that have invalid signatures
      List all local modules and their current status
      List all local and repository modules and their current status
      Reload the configuration (same as pressing the reload bar)
  reversedepends <module>
      Show all modules that depend on this one
      Show a list of upgradable modules
      Shows any annoucements that maybe displayed at for this version
  uninstall <module>
      Disable and uninstall the specified module
  upgrade <module>
      Equivalent to running download and install
      Downloads and upgrades all modules with pending updates
  enablerepo <repo>
      Enables a remote repository
  disablerepo <repo>
      Disables a remote repository
  --help, -h, -?           Show this help

sorry just amportal a dbug

Thanks. Seeing warnings:

amportal a dbug[2015-Nov-04 18:48:25] [WARNING] (libraries/modulefunctions.legacy.php:7) - Depreciated Function module_getinfo detected in /var/www/html/admin/modules/versionupgrade/ on line 35
[2015-Nov-04 18:48:25] [SECURITY] (BMO/Notifications.class.php:493) - [NOTIFICATION]-[freepbx]-[FW_TAMPERED] - You have 1 tampered files (Module: "System Admin", File: "/var/www/html/admin/modules/sysadmin/module.xml altered")

==> /var/log/asterisk/freepbx_dbug <==
2015-Nov-04 18:48:25    /var/www/html/admin/modules/findmefollow/page.findmefollow.php:33
[NOTICE]: Undefined variable: ddial

2015-Nov-04 18:48:25    /var/www/html/admin/modules/findmefollow/page.findmefollow.php:33
[NOTICE]: Undefined index: ddial_value

2015-Nov-04 18:48:25    /var/www/html/admin/modules/sysadmin/
[NOTICE]: Undefined index: deploymentid

The “tampered files” is due to an issue with system admin in which oobe is taking the screen out, so I’ve had to remove oobe from /var/www/html/admin/modules/sysadmin/module.xml again.

Separate post here: Unable to activate sysadmin after zend reset

Must be related?