Find Me/Follow Me not working

Hello,

I’m not sure what is going on but Find Me/Follow Me doesn’t seem to be working since I upgraded the system to FreePBX 12 (current stable release). I enter the number with the trailing # (xxxxxxxxxx#). Using ringallv2. Initial ring time set to 0, ring time set to 20. And confirmation is on. Before updating the system this worked fine. Any ideas?

[[email protected] ~]# amportal a ma list | grep framework
framework           12.0.1rc21        Enabled
[[email protected] ~]# cat /etc/schmooze/pbx-version
5.211.65-18
[[email protected] ~]# amportal a ma list

Fetching FreePBX settings with gen_amp_conf.php..

no repos specified, using: [commercial,standard] from last GUI settings

Module              Version           Status
------------------- ----------------- -------------------
accountcodepreserve 2.11.0.0          Enabled
announcement        2.11.0.4          Enabled
areminder           2.11.5.2          Enabled
arimanager                            Not Installed (Locally available)
asterisk-cli        2.11.0.3          Enabled
asteriskinfo        12.0.1            Enabled
backup              12.0.5            Enabled
blacklist           12.0.1            Enabled
broadcast           2.11.5            Enabled
builtin                               Enabled
bulkdids            2.11.1.2          Enabled
bulkextensions      2.11.0.7          Enabled
callback            2.11.0.4          Enabled
callerid            2.11.0.7          Enabled
callforward         12.0.5            Enabled
calllimit           2.11.0.10         Enabled
callrecording       2.11.0.8          Enabled
callwaiting         12.0.3            Enabled
campon              2.11.0.2          Enabled
cdr                 12.0.2            Enabled
certman             12.0.1            Enabled
cidlookup           2.11.1.10         Enabled
conferences         12.0.7            Enabled
conferencespro      12.0.14           Enabled
core                12.0.1rc4         Enabled
cos                 12.0.11           Enabled
customappsreg       2.11.0.2          Enabled
cxpanel             3.1.2             Disabled
dahdiconfig         2.11.47           Enabled
dashboard           12.0.15           Enabled
daynight            2.11.0.4          Enabled
dictate             2.11.0.3          Enabled
digium_phones       2.11.2.1          Enabled
digiumaddoninstaller2.11.0.4          Enabled
directory           12.0.0            Enabled
directorypro                          Not Installed (Locally available)
disa                2.11.0.6          Enabled
donotdisturb        12.0.3            Enabled
dundicheck          2.11.0.3          Enabled
endpoint            12.0.0.9          Enabled
endpointman                           Not Installed (Locally available)
extensionroutes     12.0.7            Enabled
extensionsettings   2.11.0.2          Enabled
fax                 12.0.5            Enabled
faxpro              12.0.21           Enabled
featurecodeadmin    12.0.0            Enabled
findmefollow        12.0.6            Enabled
framework           12.0.1rc21        Enabled
freepbx_ha          2.11.4            Enabled
fw_ari              2.11.1.4          Disabled
fw_langpacks        2.11.2            Enabled
hotelwakeup         2.11.3            Enabled
iaxsettings         2.11.0.3          Enabled
infoservices        2.11.0.3          Enabled
irc                 2.11.0.4          Enabled
isymphony                             Not Installed (Locally available)
ivr                 2.11.0.6          Enabled
ivrpro                                Not Installed (Locally available)
javassh             2.11.1            Disabled
languages           2.11.0.2          Enabled
logfiles            12.0.6            Enabled
manager             12.0.2            Enabled
miscapps            2.11.0.2          Enabled
miscdests           2.11.0.4          Enabled
motif               12.0.2            Enabled
music               12.0.1            Enabled
outroutemsg         2.11.0.2          Enabled
paging              12.0.5            Enabled
pagingpro           2.11.0.8          Enabled
parking             12.0.3            Enabled
parkpro             12.0.3            Enabled
pbdirectory         2.11.0.1          Enabled
phonebook           2.11.0.2          Enabled
phpagiconf          2.11.0.0          Enabled
phpinfo             2.11.0.1          Enabled
pinsets             2.11.0.8          Enabled
pinsetspro          2.11.0.9          Enabled
presencestate       12.0.12           Enabled
printextensions     2.11.0.1          Enabled
queuemetrics        2.11.0.1          Enabled
queueprio           2.11.0.2          Enabled
queues              12.0.11           Enabled
qxact_reports       2.11.0.5          Enabled
recording_report    2.11.0.9          Enabled
recordings          12.0.3            Enabled
restapi             2.11.1.20         Disabled
restapps            12.0.3            Disabled
restart             12.0.1            Enabled
ringgroups          12.0.1            Enabled
setcid              2.11.0.4          Enabled
sipsettings         12.0.3            Enabled
sipstation          12.0.2            Enabled
sipus               1.3.4             Enabled
sms                 12.0.5            Enabled
sng_mcu             2.11.0.3          Enabled
speeddial           2.11.0.2          Enabled
superfecta          2.11.14           Enabled
sysadmin            12.0.6            Enabled
timeconditions      12.0.6            Enabled
tts                 2.11.0.10         Enabled
ttsengines          2.11.0.3          Enabled
ucp                 12.0.0beta19      Enabled
userman             12.0.1            Enabled
vmblast             12.0.1            Enabled
vmnotify            2.11.0.3          Enabled
voicemail           12.0.15           Enabled
voicemail_report    2.11.0.8          Enabled
vqplus              12.0.3            Enabled
weakpasswords       12.0.2            Enabled
webcallback         2.11.0.5          Enabled
webrtc              12.0.0alpha8      Enabled
xmpp                12.0.1            Disabled

Thanks.

12 is not current stable it is Release Candidate which is Beta. I just did an OTTS class with 14 students using 12 and calling their cellphones through followme so I am generally confident this works.

Can you provide a call trace with a failed call.

Sorry, I should have said running stable release and then performed upgrade to 12.
Give me a bit and I’ll get you a trace if I don’t solve it before then. Good to know it should be working though and I’m not chasing my tail.

So I ran;

asterisk -r
core set verbose 0
core set debug 0
sip set debug ip x.x.x.x (IP of phone registered to account with follow me)

And didn’t see anything worth while. Should I be looking at the FreePBX server perhaps to catch the outbound find-me/follow-me call?

Looking at the CDR of my provider it seems like the call is being made. I see the inbound call and then an outbound call to the find-me/follow-me number. However it immediately says “Answered” even though the find-me/follow-me number never rings.

Ok, so it seems there must have been an issue with the way I was testing this, it seems to work. I tested it just a minute ago calling from my Home landline # to my office # and it followed me to my cell #.

Something in the process must have gotten smarter at some point because I use to be able to place a call from my cell # to my work # and have it forward to my cell # (call waiting). This doesn’t seem to work now.

Also, I think it didn’t work when placing a call from an internal extension to another extension that contained a follow me setting to a cell #. I’m going to test this a bit more tomorrow. Should calls from other internal extensions use the follow me settings?

Thanks.