File /etc/dahdi/system.conf is not owned by asterisk

Everything is working but I have this disturbing message in “system overview”. Was not there when I left work on Friday.

DAHDi config is 2.11.52

amportal a chown

There’s actually something to be concerned about - the file should be owned and should have always been owned by asterisk, and if it suddenly wasn’t, that hints that someone or something has changed the system.

“amportal a chown” will fix it, but you might want to look around a little bit and see why it’s suddenly an issue. Also, if you aren’t using DAHDI, the fact that it suddenly exists would be enough to make me say “Huh?”

It’s probably nothing, but if it was me, I’d take a look at the logs and see if I could figure out what changed.

Did as instructed and the notification went away, but it’s back again this morning. What can be causing this?

I have the same issue, the one thing is that we are not using anything dahdi and I beleive the code may be giving a wrong error message. In my case the files does NOT exist, so it sees it as wrong ownership.

I believe a basic file which is traditionally installed looks something like this:

# Autogenerated by /usr/sbin/dahdi_genconf on Sat Feb 13 07:28:07 2016
# If you edit this file and execute /usr/sbin/dahdi_genconf again,
# your manual changes will be LOST.
# Dahdi Configuration File
# This file is parsed by the Dahdi Configurator, dahdi_cfg
# Global data

loadzone        = us
defaultzone     = us

Should I create this same file on the system we are experiencing this on?
And should that be a suggestion for others?

Now I also see that dahdi configuration shows DAHDI is disabled for writing, which would explain why the base files aren’t there.

Any suggestions?

Try creating the file, set the ownership to “asterisk” and see what happens. If it fixes the issue, you’re golden. If it doesn’t, we can look deeper. Well, I can’t - I’m just a user. Someone can look closer. :slight_smile:

If you aren’t using DAHDI, you should leave the DAHDI write disabled. In most case, even if you are using DAHDI, you should leave DAHDI writing disabled. If you’re using it, once you get DAHDI working, you don’t want to touch it again.

Known issue and fixed with edge framework:

1 Like