File custom/MYSOUND does not exist in any format


even though I know there’re a few other tickets with the same or similar title, I didn’t found a solution to my particular problem. It seems this errormessage spawns for the similar reason (file not found), but it arises from different causes.

Info - PBX
Asterisk Version 17.9.4
FreePBX Version 15.0.37

Errormessage [ /var/log/asterisk/full ]

pbx_builtins.c: Goto (play-system-recording,5,1)
file.c: File custom/MYSOUNDFILE does not exist in any format
file.c: Unable to open custom/MYSOUNDFILE (format (alaw)): No such file or directory
app_playback.c: Playback failed on PJSIP/MY_Outbound-xxxxx for custom/MYSOUNDFILE

Info - Settings

  • I created a new Timecondition where a System Recording should be played if the condition wasn’t met.
  • The System Recording was already used earlier for a different purpose; so it worked at one point in time.
  • I’m able to manually listen to the soundfile under Admin / SystemRecordings
  • I converted the file to all the available formats (wav, alaw, ulaw etc.)
  • The relative path for the file is custom/MYSOUNDFILE
  • The absolute path is /var/lib/asterisk/sounds/de_westany/custom/MYSOUNDFILE
  • In my asterisk.conf file, there’s no entry for astdatadir


  • Changing the path in the /etc/asterisk/extensions_additional.conf from a relativ to an absolute path will work
relative path
  exten => 29,n,Playback(custom/MYSOUNDFILE)
absolute path
  exten => 29,n,Playback(/var/lib/asterisk/sounds/de_westany/custom/MYSOUNDFILE)
  • setting the astdatadir directory in the asterisk.conf file to /var/lib/asterisk doesn’t fix the problem either
  • setting the astdatadir directory to a deeper path like /var/lib/asterisk/sounds/de_westany/ (regardless of trailing / or not) results in asterisk not restarting or not connecting
In Start.class.php line 193:
  Unable to connect to Asterisk. Did it start?  

Even though this works, I don’t consider this a solution to the problem, since I have to alter asterisk files manually, without the certainty of these files to be stable/unaltered during/after an update.

Is there a way to make system recordings available again for FreePBX/Asterisk?
Is there a way to check the current path for astdatadir?
Is there a way to set the path to the system recordings from inside the FreePBX GUI?

I hope these information are helpful. Since I’m out of ideas on how to fix this problem of recordings not found by asterisk even though they exist, any help is appreciated.

Thanks in advance

When you add the recording in System Recordings. do you change the “File List for English” field to Czech before submitting?

Hello Comtech,

No, I don’t change anything when I add a recording in Systemrecording (beside the format, description etc.). The Field File List for German Westany is preselected with German Westany

Btw. the problem didn’t exclusively occur on a newly added recording, but also on old recordings (see quote) that were working earlier. So I would conclude adding files under System Recordings is not the root of the problem.

As a workaround I now created a symlink for the custom -Folder in the de_westany -Directory to the en -Directory

/var/lib/asterisk/sounds/en/custom -> /var/lib/asterisk/sounds/de_westany/custom

This works but still doesn’t fix the Problem nor does it explain it. But maybe the workaround is helpful for some.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.