FaxPro Module all outgoing faxes fail with "The call dropped prematurely"

Hi all, every fax I try to send out fails. I get a The call dropped prematurely response and if I check traces I get a “488 Not acceptable here” response to this invite:
INVITE sip: SIP/2.0

t=0 0
m=image 47090 udptl t38

Anyone can give me any help please?

generally that points to codec negotiation

does the trunk provider support t38 ? they should be able to tell you why if they are the ones rejecting it

a wiresharked transaction might help too

1 Like

let me give you some advice on fax. It sucks. Go with a fax provider and do NOT use your pbx. t38fax.com is the way to go. Your faxes will be hit or miss. I worked on this for 5 years and it doesn’t work. your welcome

Do you have your UDPTL ports open on the PBX? This is the most common issue other than needing a reliable T.38 provider. I use about 3 and load balance them. So faxes alternate. After 10 years Im pretty sure its perfected.

Hint…to see if a fax is going t.38 or g711 run sip show channelstats or fax show sessions.
If youre running this over an ata you wont see either unless its g711. almost every carrier has ECM shut off for t.38. Verizon and T.38fax.com keep it on. Level 3, IQ have it shut off. Most carriers dont support t38 at all. It can work reliably though. Just takes lots of work.

Everyone knows open 10K-20K but faxes use different ports entirely. You can set those to whatever you want. The defaults of under 5K arent the best option.

Thanks for your help, I’ll check UDPTL ports but I’m quite sure they are open.
T.38 should be supported by my provider because we don’t have any problem on incoming faxes.
I’ll chek with sip show channelstats and I’ll let you know.
I agree with Sentinel on faxes being a drag… a lot of setup/tuning work to send/receive maybe 3-4 faxes a year…

Fax show session shows no ECM, Sip Show Channel seems to indicate there is no T.38.

FAX Session Details:

session : 207
operation : Transmit
state : Active
Last Status : OK
ECM Mode : No
Data Rate : 9600
Image Resolution : 8031x7700
Page Number : 1
File Name : /var/spool/asterisk/tmp/fax-1570704938557.tif

  • SIP Call
    Curr. trans. direction: Incoming
    Call-ID: 125c76cf474dedb72816b1ea1323c76f at c.voceblu.it
    Owner channel ID:
    Our Codec Capability: (ulaw|alaw)
    Non-Codec Capability (DTMF): 1
    Their Codec Capability: (ulaw|alaw)
    Joint Codec Capability: (ulaw|alaw)
    Format: (nothing)
    T.38 support No
    Video support No
    MaxCallBR: 384 kbps

I can’t attach pcap or links because I’m a newbie… sorry.

sip show settings here is mine but datagram thing is optional.
T.38 support: Yes
T.38 EC mode: Redundancy
T.38 MaxDtgrm: 300

UDPTL show config

UDPTL Global options

udptlstart: 10002
udptlend: 10998
udptlfecentries: 3
udptlfecspan: 3
use_even_ports: No
udptlchecksums: No

Dont overlap ports by setting like mine. By default its 4000-4999. I assume you dont have t.38 enabled judging by your settings.

Also under fax settings i set 9600 to 14400 ecm on.

I switched T38-Gateway Enabled on and off in outbound route but did not see any difference. Is that the correct setting to use? How can I check otherwise is it is enabled?

update: udptl_custom.conf was empty so I filled it in with default values and got a different error message: Received no response to DCS or TCF. Not solved but an improvement?
Still no T.38 in sip show channel though

Sip settings, t38 enable.

Custom conf is always blank. Its for custom settings.

You put your custom settings in there. I keep gateway off in outbound routes as it causes failures for me.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.