Faxing setup for Freepbx

I have a freepbx (distro version 6.12.65-23) and we have the fax-pro module. I have a digium PRI card (WCTE23X) with all faxing DID’s coming in over that card. Faxing is not working well at all. We can get 1-5 pages pretty consistently but anything more than that fails routinely complaining about line quality. The PRI is a traditional TDM PRI and is running clean. It appears that I’m using the spandsp module although I’m not sure how to be certain. When I’m in the CLI I see this when I give the command module show like fax
Module Description Use Count
res_fax.so Generic FAX Applications 2
res_fax_spandsp.so Spandsp G.711 and T.38 FAX Technologies 1

So it appears I’m using both somehow. I’m not sure how or why. I see this in the logs routinely when recieving or sending faxes.

[2014-12-31 14:31:28] WARNING[26183][C-00000661]: res_fax_spandsp.c:434 spandsp_log: WARNING T.30 ECM carrier not found
[2014-12-31 14:31:28] WARNING[26183][C-00000661]: res_fax_spandsp.c:434 spandsp_log: WARNING T.30 ECM carrier not found

Many of the longer faxes will retry up to the retry count and I’ll get a bunch of partial faxes through 6 of 14 pages or something like that. Faxes are broken in and out bound.

Can you help me understand what may be wrong here?

Couple of comments,

A check your /etc/asterisk/logger*.conf files for duplicate log file entries,

B T30 is a lot more picky for FAX than G711 is for voice alone, and for a PRI ypu can only use T30 over G711, (make sure you are using the right variant. (m)ulaw or alaw), You say it is “is running clean” but have you ever balanced your RX/TX gains against a milliwatt test while watching the issue of dahdi_monitor? My guess is you are “out of whack” there, if you do that necessary tuning, both your FAX and VOICE call experience will likely improve dramatically.

Dicko, thanks for the reply.

I am not sure what you mean by checking for duplicate log entries. Can you elaborate on that for me?

It is using g711 and the PRI is only for voice. I am not sure how to run the test you recommend. Is this all done within the dahdi_monitor?

I will check on the codec suggestion. I certainly have never had to make changes to that with this carrier in the past. BUt this is my first time trying to have Asterisk do serious faxing for us.

For milliwat testing, find an appropriate local milliwatt test number and you can follow:-

Thanks again. The results seem strange to me. My RX is almost 100%, but my TX is like 1% or so. Pretty consistently. Do you have any ideas on what I may doing wrong? or is there something else going on?

Not really, I have no experience with res_fax, but 1% TX level is definitely going to be a problem, perhaps the milliwatt number is not working, did you call it from a phone. or it diodn’t connect to the milliwatt app, post a call log.


Do you know where I may be able to take this discussion to find someone who has experience with this and can help me figure it out, by chance?

after having run for a while we are seeing routine failures sending out and the error is coming back on the fax application as no response after sending a page. THe fax will send the first page and the UCP shows that it has begun trying to send the second page. However when I’m on the CLI and running fax show session XXX where XXX is the session I’m trying to watch, the page number never goes to two. And it continues to try and send until it fails outright.

I have been working on the gains and it really makes no difference on the numbers that are having this trouble. Other fax machines are working, but many are failing, probably 80% failure at this point.

Another oddity, I have ecm turned to no in the Fax Configuration form, but the ECM is always negotiated and used.

Again, I can’t be of help here, I don’t use any of FreePBX’ fax utility, just the fax detection (CNG) of Asterisk/Dahdi to redirect incoming fax calls to appropriate endpoints with res_fax_spandsp. Sorry.

Thanks again Dicko,

I chose the commercial modules forum because we are using the Fax Pro module. I wonder if anyone at Freepbx could give me a hand with this. We were sold a really solid solution in this Fax Pro module at Astricon but we seem to have received less than that. I’m about to switch faxing back to hylafax if I can’t get this working soon. Which would be a shame since the customer is hoping to utilize the nice integration with UCP.

It is asterisk 11 BTW.

I am able to consistently get large faxes through at about half of the sites we have tried.

The issue does seem to be related to compatibility with the receiving fax machine. The issues is it’s about half of the machines we are sending to that are having this issue. I can send 50 page faxes to other fax numbers no problem. However when I try to send even one page to a failing fax machine, it fails ever single time. I have played with the rx and tx gain, I have changed my codec from ulaw to alaw and back, I have tried lowering my lowest speed setting in the fax pro module, I have tried turning echo cancel off and on, I have tested with ecm off and on, I have tried various pdf files. I am out of ideas. THe PRI is clean, no slips no errors. When I send to a fax machine that we are compatible with the speed remains at the 100% speed of 14400 for the entire 50 pages. So I don’t believe I have a line quality issue. Debug give me no other info. The error is always the same, “Status: No response after sending a page”.