Fax to Mail on FreePBX Distro 13

Hey there,

I am in trouble with the configuration of Fax to Mail on the FreePBX Distro 13 (10.13.66-6).
I had configured everything for calls without no problems but incomming faxes wont be send to my configured e-mail destination.

What I had done yet:

  1. Configured “Fax Optoins”: hxxps://pl.vc/3tpbs
  2. Activated T38 Passthrought in “SIP Settings -> Chan SIP Settings”: hxxps://pl.vc/4rlwt
  3. Added an virtual Extension, so this one can forward the fax as mail: hxps://pl.vc/5wu3x | hxxps://pl.vc/rrkt
  4. Edit the user which is associated with the new Extension to activate fax and enter an e-mail address: hxxps://pl.vc/2gug1 | hxxps://pl.vc/5bola
  5. Edit the new Inbound Route for the Extension to set “Fax Recipient” as Destination, detect Fax is not activated!: hxxps://pl.vc/5umy7

Images hosted by picload.org

For testing I try to call my fax. The call will be answered with some “piep” sounds but after 21s it will Hangup, so I tried to send a real fax and watch into the asterisk console log: hxxp://pastebin.com/60VLBEc1

After some hours of google and this community I decided to write here in hope someone has an idea what I have done wrong. All solutions I could found for older asterisk and FreePBX version does not solve my issue.

Thanks for help,


Try setting the T38 passthrough option to No. I’ve set up incoming fax to forward to mail in a way similar to yours, only this option was disabled.
The fax got through using ulaw and not T38 though.

Thanks for replay.

Now have deactivaded T38 passthrough and get the exact same Error messages =/

My ISDN is incoming through an Beronet Berofix PCIe Card, I also tested now to deactivate the T38 support there but nothing changed.

Another idea?

Cannot find anny solution.


What is the network configuration of the PBX? Is it behind NAT? If so, this issue can happen if either side has communication issues. Saw this recently when a dlink router was involved and had to disabled the UDP security in the router and then faxing worked fine.

There is no NAT. Other E-Mail functions work, for example the update alert.
Also normal calls are working.

My construction consists of one server with the FreePBX Distro, the Beronet Card is inserted here, and some phones, nothing would be routed. The ISDN is directly connected to the server by the Beronet card.

The network is configured manually in the console, cause I need a bridge interface to access the Beronet card.
If necessary I can provide it via pastebin.

Thanks for your help.

You are not going to receive an email if the fax negotiation and receive process doesn’t complete and result in a received fax. How is the far side receiving and have you capped your fax receive speed under settings, fax configuration to no more than 14400?

This behavior explains why there is no .tiff file which is mentioned in my log files.

The far side receiving fax directly to an analoge fax.

The highest value under fax configuration is 14400, I also tried 9600 for both but nothing changed.

This sounds like a communication issue which can be caused by dahdi drivers, network configuration, fax/ATA configuration, fax machine configuration, etc. Without more specifics about call paths and settings on every device being used along the way, it is almost impossible to troubleshoot this way. If the ATA and fax machine are on the same LAN, I would look at the configuration of the ATA and fax machine first. Ensure the fax machine is configured to negotiate at 14400 or lower also.

Sorry but now I am confused.

I like to get an incoming fax as an E-Mail so I have the following sequence of events:

any sending fax – via ISDN —> my Beronet Card —> FreePBX Inbount Route for this number —> Fax Reciptient – create PDF —> E-Mail to defined address of the User

In this scenario I cannot take influence about the ATA or the fax machine, can I?

The sending of faxes is irrelevant at the moment for me.
My configurations are linked in my first post. Nothing more is configured by me, cause in my mind there is nothing more to configure.
I am no guru in this section of technology, so please explain if I am completely wrong.

Network configuration:

#Beronet#--------------> PC




if you look into your asterisk logs, do you see any messages related to a communications timeout? If this is not the problem, it is likely a fax negotiation issue when the fax tones start.

In /var/log/asterisk/full I can only found the loading of timeout module, no error.
The only errors I get are:

“FAILED: error: Disconnected after permitted retries statusstr: Disconnected after permitted retries"
"FAILED: error: Disconnected after permitted retries statusstr: Disconnected after permitted retries” for: user_email , From: “030987654321” <030987654321>"

Is there a way to tesst the fax negotiation?

I discovered some new information:

It seems that the error: “Disconnected after permitted retries” comes from SpanDSP in fax phase E, it has its own error code (78, source: hxxp://asterfax.sourceforge.net/SpanDSP.html).

So if I do understand the fax process correctly phase E is the last phase in whiche a fax connections will be closed. This means my fax communication worgscorrectly right? Only the closing process faulty.

Is this an possible idea or only rubbish?

Regards TomHans

Additionally I noticed that the message comes from case “T30_ERR_RETRYDCN” of the spandsp source (hxxps://github.com/rillian/asterisk-opus/blob/master/res/res_fax_spandsp.c)
I think this means also that the protocol T30 is used instead of T38 or G.711.

For everyone who reads this:

my configuration was completely correct, but the connection from ISDN was incorrect. I had an DSL connection which have to be splitted into ISDN.

Thanks for everyones help.