FAX passthrough issue

I’m having an issue with a FAX passthrough configuration, from time to time and with certain external FAX machines more than with others.

We assume that the external FAX machine is connected directly to the POTS or via a classic PBX.

When our internal FAX machine is also connected through a classic PBX, it can send FAX without any problem all the time.

On the other side, when it’s connected via the FXS port of a LinkSYS SPA3102, itself linked to a FreePBX IP-PBX which is hooked into the POTS via a XORCOM XR0055 interface, then it doesn’t manage to send a FAX to that specific external machine, while it may be able to send to other external FAX machines.

Any ideas why is that so and how to solve it?

FreePBX and Asterisk 1.4.36

That is because SIP and VOIP is not designed to handle fax. once you convert it to SIP with the ATA all bets are off on it working

I hear what you say, nonetheless what I see with this specific deployment’s FAX server, for instance, is that while during the day of Yesterday were sent 39 outgoing FAXes, only two amongst them failed with the message “Failure to train remote machine” and both were attempts to send to the same outside FAX number.

It seems to me that if the main reason was due to SIP and VoIP non having been designed for FAX transmission, statistically we should have had a wider spread over different numbers.

The difficulty with a specific number to me hints at some peculiarity with that specific hardware. Am I wrong?

Well, yes different fax machines seem more or less tolerant. The whole process of digitizing a synchronous fax stream and packetizing it into an asynchronous stream is ripe with opportunity to insert artifacts, twist, phase coherency issues etc. It is surprising it works at all.

If you are serious about fax you need to tune up Asterisk so that t.38 works. The t.38 protocol negotiates the fax protocol with the ATA. Asterisk 1.8 has full fax gateway features. They are just not all exposed in FreePBX.

If you install the commercial fax module and set your ata for t.38 you will find most of the hard work done for you. Tony and I operate a commercial Asterisk fax gateway and process 100’s of faxes of day without issue.

I have this working with Vitelity. There are so many variables. Good network and ISP connection and can your SIP carrier handle it. I have this working both on my 1.4 and 1.8 boxes.
Here is what I did. In advance SIP settings.
T38 Pass-Through = Yes
Now create a file in /etc/asterisk. Call it udptl.conf.
Here is what I have in it.

;T38FaxUdpEC = t38UDPFEC
T38FaxUdpEC = t38UDPRedundancy
T38FaxMaxDatagram = 400
udptlfecentries = 3
udptlfecspan = 3

This works for me on every box I place this in.

Good Luck