Fax over T.38, SIP trunk

Hi, I got configured SIP trunk with my Telco, and the calls working as it should but I got problem with outgoing fax…
Incoming fax is working great, no problems with it at all, but the problem is the outgoing fax.
FreePBX is configured to use T.38, as the telco told me that is the only way to send a fax over their SIP trunk.

This is the configuration of the system:
Fax device — ATA adapter (HT502) — FreePBX (passthrough) – Telco

Analyzing the logs I’ve found that when I send the fax, T.38 reinvites are sent by ATA adapter, and the fax is always successful, but with the incoming faxes, T.38 reinvite are sent by telco, always. Here I got the BYE message from Telco (Huawei SoftX3000):

Reason: SIP;text=“Session Timer Check Message Failed for INVITE 2xx”

Here, the session is disconnected by the remote end, and the fax call is dropped.
I tried to change “session timer” options, parameters for UDPTL protocol, different FAX devices, ATA adapters…

I appreciate any help :wink:


I tried with Grandstream ATA HT502 and Cisco SPA112 but with no success :frowning:

Asterisk v.11 can act as a T.38 gateway as far as I know… I thought I could try sending fax from FreePBX but I’m not sure how to do it. Any suggestion ?


I use only the Grandstream HTC502 for faxing with fax machines. Now, I’m not sure if I need T.38 for it (probably) but I’ve been able to send and recieve faxes successfully for about 1/2 dozen clients. I do not have any T.38 settings enabled in FreePBX or any internal extension. I simply setup an extension as if it were a phone and plugged those details into the ATA. Then, I use the following settings on the line of the HTC502.

I point a DID to the extension, test with the HP fax test line (1888, and it just works. For this “traditional” method of using fax, I don’t use any fancy FreePBX modules or addons, just straight extensions and DIDs.

I hope this helps!

Are you having a SIP trunk with your telco or traditional lines ?

I’m using 100% SIP for everything