Fax For Asterisk No Fax license detected?

So I installed and configured FreePbx and Asterisk on Ubuntu 9.10 for my parents recently. i have a trixbox running at home and am using what FreeBDS call legacy fax support for fax to email and it works great for me however i am unable to get this working for them so i decided to try Fax For Asterisk. i got my free key and installed it following the directions from the read me @ http://downloads.digium.com/pub/telephony/fax/README
however once i get to the check your license part in the readme by using the command:

voipserver*CLI> fax show stats

the only output i get is:

FAX Statistics:

Current Sessions : 0
Transmit Attempts : 0
Receive Attempts : 0
Completed FAXes : 0
Failed FAXes : 0

this has no reference to the license like it does in the readme i do have the license file @ /var/lib/asterisk/licenses
but when im in the FreeBDS interface and goto an extension i am unable to set the extension to handel fax as it says

ERROR: No Fax license detected. Fax-related dialplan will NOT be generated! This module has detected that Fax for Asterisk is installed without a license. At least one license is required (it is available for free) and must be installed.

i have searched allover but cant find a solution

any help would be great!



Can you tell me the output of ‘show modules like fax’ from the asterisk cli?

maybe im doing this wrong?

voipserverCLI> show modules like fax
No such command ‘show modules like fax’ (type ‘core show help show modules’ for other possible commands)

You should get the following output:

show modules like fax
Module Description Use Count
res_fax.so Generic FAX Applications 1
res_fax_digium.so Digium G.711 FAX Technology (optimized f 0
2 modules loaded

Try ‘module load [module_name]’ and see if they modules can even load in asterisk.

what should i put for module_name?
or do i put it just how u typed it?

if so
Command ‘module load [module_name]’ failed.

oh and is this normal?

== Manager ‘admin’ logged on from
== Manager ‘admin’ logged off from
== Manager ‘admin’ logged on from
== Manager ‘admin’ logged off from
== Manager ‘admin’ logged on from
== Manager ‘admin’ logged off from

it keeps repeating every few seconds

You should be doing ‘module load res_fax.so’ and then ‘module load res_fax_digium.so’ if your using Fax for Asterisk. What version of asterisk and what version of Fax for Asterisk are you using?

The information you are seeing regarding the manager logging and and out is normal activity.

voipserver*CLI> module load res_fax.so
Unable to load module res_fax.so
Command ‘module load res_fax.so’ failed.

voipserver*CLI> module load res_fax_digium.so
Unable to load module res_fax_digium.so
Command ‘module load res_fax_digium.so’ failed.

Asterisk Ver.
and i installed these 2 for fax in the readme the benchfax would not run so i chose generic as im on an atom based comp and that wasnt an option in at http://www.digium.com/en/docs/FAX/faa-download.php

res_fax: res_fax-
res_fax_digium: res_fax_digium-

Can you verify you have res_fax.so and res_fax_digium.so in /usr/lib/asterisk/modules/?

sure do

ok so it now knows it licensed i started allover again and this time it just worked! very weird!
thank you so much for your help!

however how do i detect incoming faxes with it? on my trixbox im using the nvfax and it has worked well for me however in FreePBX this options is greyed out so that leaves me with zaptel or sip
i made a virtual extension and set fax detect to send to there i then set the virtual extension to detect faxes and email me

but it does not seem to detect at all if i watch in the CLI it always gets sent to my ring all group

What method of detection did you chose - dahdi or sip?


can you provide the output of the following CLI command (or it’s appropriate equivalent depending on what Asterisk version your are using):

show modules like fax

I’d like to see what your nv fax module looks like in that listing to see if we are not detecting nv_fax properly. The code is suppose to detect it and only show it as an option if you have it installed. (In the past, it presented the option always which would lead to hung up calls if it was configured where there was no nv fax installed on a system).