FAX Extension

At:

Connectivity -> Trunks -> {PJSIP Trunk} -> pjsip Settings -> Advanced

There is an option:

Fax Detect Yes/No
This option can be set to send the session to the fax extension when a CNG tone is detected.

Where is the fax extension defined?

On the Fax tab of the Inbound Route. The trunk option merely causes pjsip to detect the switch to T.38 and alert the higher level code. It’s equivalent to faxdetect=yes in a chan_sip trunk.

Unless you have a strong reason for doing so (printed brochures, vanity number, etc.), I recommend against using the same number for both voice and fax. Fax detect must answer the line and ‘listen’ for 4 seconds or more before processing the call. This is not only a delay but the fake answer causes calls not actually answered to be billed (at one or both ends if applicable) and results in misleading log entries.

From your other threads, it appears that you are in US, where incoming numbers are almost free. Low cost numbers suitable for personal or SOHO fax include https://www.callcentric.com/dids/dollar_unlimited_phone_number (can be routed to their fax receiver; no PBX needed), https://www.localphone.com/incoming_numbers/united_states and https://signalwire.com/ .

Bigger fish can add a DID to their SIPStation account for only $1/mo.

Also fax options in freepbx do not apply to hylafax which is what @reraikes uses.

Can you please explain? I was under the impression that hylafax functioned as an ‘extension’ and until the call is transferred there it simply doesn’t get executed. Does it somehow have hooks that enable a DID to be used for both voice and fax?

HylaFAX + IAXModem interfaces as a regular extension which is then specified as the destination in an inbound route.

Thanks Stewart.

Installing the ‘Fax Configuration’ module got the Fax tab on Inbound Routes which contains the ‘Fax Destination’ option.

In this case, I want to share a single DID between FAX (primary usage) and DISA (very rare usage), so there’s not a problem. Everything appears to be working exactly as I had hoped.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.