Fax Detection with PBX IN A FLASH


To continue the conversation from the bug posting. It appears to be isolated to PIAF and not Freepbx.

As requested I tried to run “module show like fax” but it says command not found.

You are running the wrong command. Or running it incorrectly. You need to run that command inside Asterisk. Is that where you ran it? Your wording makes it sound like you ran it directly on bash. Which is wrong.

Here is the example output (and like I tried to tell you in your ticket, you need the fax configuration module which will attempt to detect res_fax_*, since you are missing those contexts I am assuming you don’t have the proper components installed)

freepbxdev1*CLI> module show like fax Module Description Use Count Status res_fax.so Generic FAX Applications 1 Running res_fax_spandsp.so Spandsp G.711 and T.38 FAX Technologies 0 Running 2 modules loaded

Sorry… my apologies… I didn’t catch you before hand.

I realised I was running it in the wrong place…

Here’s what I have:

Module Description Use Count
app_fax.so Simple FAX Application 0
1 modules loaded

I’d recommend trying to recompile asterisk on your PBX in a Flash with res_fax (which is a core support module) and res_fax_spandsp (which is an extended support module like app_fax) as I bet app_fax is what is causing problems for you.

Sadly it’s still not working… Ext-fax seems to show up now, but it still can’t detect faxes… same issue as originally reported.

NOTICE[30939][C-00000004] chan_sip.c: FAX CNG detected but no fax extension

After some thought… I’m just going to put this headache behind me… and join the FREEPBX DISTRO clan… I’m not happy with some of the support PIAF has given through this issue, and from what I can see, FREEPBX DISTRO works nicer. I will miss some incredible pbx features, but for the few I loose, I’m sure I can live without… I just feel we could spend months trying to fix this fax detection issue, and without PIAF supporting finding a solution, I rather go with something that is going to work and work out of the box… Thanks to everyone on here for the help…


For whatever features you feel you are missing file a feature request, you already know how to do it so we welcome your input and remember to report bugs in the future if you have any other issues.

For some clarification we actually did test this issue on about 3 systems in the office and then one remote that I have along with about 3-4 phone calls between Tony, Bryan and myself. It wasn’t just “passed along” (note I never said you said that, I am just pointing out how we work through individual tickets)

The only difference I can see in faxing from PBX in a flash and freepbx is the usage of res_fax and span_dsp both of which are provided in the source of Asterisk.

No worries,

I’m more upset with the PBX IN A FLASH people who seemed to be in complete denial, and refused to even actively look into things. Some of which only could say “just get a 2nd line” which does not fix a feature, just works around it, and costs us more cash for what few faxes we do recieve which is why we moved to a single line years ago. :slight_smile:

Your team here although seemed like they actively cared, and you should be proud of that. There was a moment when PIAF pointed at you guys and you pointed at them I felt frustrated, but you took it further, which is what customer service is about!

I really do appreciate it.