Fax confirmation email-never receiving it

I have in and out fax working. No problems. But when sending a fax, it never sends the confirmation email even when the fax goes through. I have checked everything and can’t figure it out. It sends the fax out via the email account I set up in Webmin/SMTP Authentication.

Thank you in advance!

The server in question
I have FreePBX Core with Asterisk 11.2.1 (Asterisk 11.2.1 built by root @ 237-138-19-10.digium.internal on a i686 running Linux on 2013-03-06 18:56:51 UTC) The only editing I have done at the CLI level was to some of the .conf files, as directed by instructions, to get the Digium Free Fax License to work.

My background
Although I have 25 years experience in I.T. and my own I.T. corporation, I just got into FreePBX in January 2014 using the FreePBX distro. Despite being new, I have probably accumulated about 200 hours of experience on the FreePBX system. I have set up two FreePBX servers (one 32 bit and one 64 bit) and learned about every feature of the base FreePBX, a few add-on supported modules, and even set up the free Digium Fax License on both servers (that by far was the most difficult process I had to do on FreePBX.) I have set up custom inbound routes that route my cell phone to a “the system is working” message so I can check on my systems. The only thing I have not gotten into is auto provisioning. Finally, I have set up about 20 Yealink T20 and T28 phones. (BTW, I really like the Yealink phones on both the user and admin level. Other than setting the custom graphic on the T28, these phones are super easy to configure.)


echo “THIS IS A TEST” | mailx -s “TEST” [email protected]

Replacing [email protected] with a valid email
Also check your spam box.

Looks like the forum software wrapped the text. It is all 1 line.

I tried your command to two different email address I have and it worked instantly.

Oh, and I am having this issue on two separate servers in two separate locations, on two separate Verizon FIOS accounts.

BTW, since I am on Verizon Fios and they don’t allow you to set up an outgoing mail server (at least, not easily), I route all outgoing through a gmail account by setting it up in Webmin/Postmail/SMTP authentication. And that is the route the echo tests took (the emails show they came from that account). I don’t see anything in my SPAM or JUNK folders either. Any more ideas? Thanks for the help.

I bet its something with Fax for Asterisk. Everything we built Fax Pro for was ontop of SPANDSP not fax for asterisk.

I am having the exact same issue, did you ever find a solution? Faxes send fine, but no confirmation is sent and ECHO’ing a test email works.

No, the problem has not been resolved. I really wish I could find the issue, but it sounds like a bug in the program.