FAX CNG detected but no fax extension

So I was able to get FreePBX, Vitelity and a Cisco 9971 mostly working thanks to some awesome posts here in the forums. Right now I am moving on to the next step which was to take my previously configured and functional SPA112 (configured directly to Vitelity) and move it to work under FreePBX. The SPA112 is being used as an ATA to supply a fax machine with the line it needs to function. I have Line 1 of it still configured directly to Vitelity and that works fine when I route calls to that subaccount but when I try to run it through Line 2 and route calls through FreePBX I get the following error.

[2016-06-23 15:09:36] VERBOSE[25315][C-00000046] app_dial.c: Called SIP/1001
[2016-06-23 15:09:36] VERBOSE[25315][C-00000046] app_dial.c: SIP/1001-0000005a is ringing
[2016-06-23 15:09:41] NOTICE[25315][C-00000046] chan_sip.c: FAX CNG detected but no fax extension
[2016-06-23 15:09:41] NOTICE[25315][C-00000046] res_fax.c: FAX CNG detected but no fax extension in context (ext-group)

Based on that I know that fax detection is working correctly. When configuring FreePBX, I did the following:

  1. Created a new CHAN_PJSIP extension for the SPA112 to connect to (1005)
  2. Modified my incoming route options to Detect Faxes via SIP and send them to extension 1005 previously created.
  3. In Asterisk SIP Settings -> SIP Settings -> Chan SIP Settings -> Advanced General Settigngs I added faxdetect=yes

If I recall there was another place to enable T38 but I did do that as well.

The question I have is what steps did I possibly miss? I don’t see a way to create an extension that is specifically defined as a fax extension or any flags to switch when creating an extension for it. I can go to the Fax settings under a user but that doesn’t look like that affects anything for an ATA configuration, it looks like that would be used for digital configurations faxing without a physical fax machine.

Thanks for any help!

Anyone have any thoughts?

Hi,

Has anyone resolve this? as I’m getting the same error…

You create a pjsip extension and then add faxdetect on chan_sip??!
Also did you try to change your extension context?

In my original post I had stated I created the CHAN_PJSIP for the SPA112 which connects. Then I modified the incoming route options to detect faxes and send them to that extension. And I modified the Asterisk SIP settings for chan sip to add faxdetect as well. The DETECTION is working. The EXTENSION is not being used as a fax extension as the errors states. Any documentation I see on this says to click the check box on the extension to indicate it is a fax however that option does not exist.

Open your extensions_custom.conf file and put this over the from-internal-custom

[ext-group-custom]
exten => fax,1,Noop(Fax detected!)
same => n,Dial(Local/[email protected])

Ok, so at the file system level (not in the UI) it looks like /etc/asterisk/extensions_custom.conf exists but is empty. In that case do I just place those three lines in the file and thats it? And for my reference, it looks like if I were to change the extension used, I would just change the reference to 1005 in the third line?

Yes just put them there. If you want to change the extension that will receive the fax change 1005 to whatever you want.

Awesome thanks! I’ll add them now and test it out. Do I need to restart any services once I have made the change?

Just reload asterisk to read the new configuration. If you don’t know how to do it just edit an extension, don’t change anything and press submit/apply changes that will reload asterisk.

Cool thanks. Hopefully this is all I need to get it working and that I have all the required T38 settings enabled. I’ll try to test this out today!

I’m using Vitelity and have the ATA working direct to them bypassing FreePBX already so I know the T38 and faxing does work.

Looks like incoming is now working, yay! Thank you! Though now I have an outbound issue where it doesn’t seem to want to transmit (attempts then fails and retries). Should I create a new thread for that or is it acceptable to continue on this thread? Since its probably a different issue?

Make a new one as it should take some posts to figure out what is happening. In the meantime try to lower your speed at the fax machine.

Will do, thanks for the help @astbox!

1 Like