FATAL ERROR DB Error: not found

PHP was upgraded to 5.5.3, then all kinds of things broke. We returned it back to 5.3.27 and we’re still getting errors. The asterisk part works, phones are registered and calls are processing, we can get into MySQL with the asteriskuser account just fine; just the FreePBX interface is throwing the error below. Any help would be appreciated!


DB Error: not found

Trace Back

/var/www/html/admin/libraries/db_connect.php:63 die_freepbx()
[0]: DB Error: not found

/var/www/html/admin/bootstrap.php:98 require_once()
[0]: /var/www/html/admin/libraries/db_connect.php

/etc/freepbx.conf:9 require_once()
[0]: /var/www/html/admin/bootstrap.php

/var/www/html/admin/config.php:112 include_once()
[0]: /etc/freepbx.conf

Do the contents of /etc/freepbx.conf look correct?

Thank you for your response!

Yes. The username/password/host/db are all correct. If I use those values from the command line (mysql -u asteriskuser -p) then ‘use asterisk’ it works just like it should… I’m really at a loss here… I’ve tried rebuilding PHP 4 times with various options and cannot get this resolved.

I was able to solve it. The issue came from Pear. In case someone else has this problem, I ran the following commands to fix it…

$ wget http://pear.php.net/go-pear.phar $ php go-pear.phar