Fastweb: non riesco a fare chiamate in uscita “tutti i circuiti sono momentaneamente occupati”

Salve a tutti, ho come provider Fastweb. Ho gia richiesto le credenziali VoIP e con router Fritzbox tutto funziona alla perfezione. Volevo provare ad installare freepbx, ma durante la configurazione vedo che il trunk si registra, ma le chiamate inbound e outbound non funzionano (inbound ogni tanto si non capisco perché). In uscita mi esce il messaggio “tutti i circuiti sono momentaneamente occupati”. Qualcuno ha già riscontrato questo problema con fastweb o con qualche altro provider? soluzioni?

Grazie a chiunque proverà ad aiutarmi.

Hello yall, at home ive fastweb connectivity, I have already requested VoIP credentials and, using a Fritzbox router, everything works perfectly. Id like to install freepbx, but during the configuration I see that the trunk is registered, but the inbound and outbound calls don’t work (inbound once in a blue moon works, dk why). On output I get the message “all circuits are temporarily busy”. Has anyone already encountered this problem with fastweb or with some other provider? solutions?

Thanks in advance.

Possible causes of intermittent incoming:

  1. Another device (IP phone, softphone, mobile SIP app, etc.) is registering with the same credentials, and the server is replacing the PBX registration when that occurs. Confirm that with the PBX shut down, the Fritzbox or Fastweb shows no registration.
  2. A NAT association is timing out, so incoming calls (which look like ‘replies’ to REGISTER) are being dropped. To test for this, attempt an outgoing call (it doesn’t matter if it fails), then immediately (within 30 seconds), call in from your mobile. If this call succeeds, it’s probably a NAT timeout. Try setting Expiration to e.g. 120 seconds.

If neither of the above, report what, if anything, appears in the Asterisk log when an incoming call fails. If nothing, run sngrep and report what, if anything, appears there. If also nothing, describe all network elements between the PBX and the internet.

I’m assuming that you are using a pjsip trunk.

That just says that Fastweb rejected the call. In many cases you can fix that by setting (in the trunk) From User to the same value you have in Username and From Domain to the same value you have in SIP Server.

If this doesn’t help, at the Asterisk command prompt type
pjsip set logger on
make a failing call, paste the Asterisk log for the call at and post the link here. If you are too new to post links, just post the last eight characters of the URL.

After i wrote the topic, i solved the problem with incoming calls. I also tried to " From User to the same value you have in Username and From Domain to the same value you have in SIP Server" and it worked only for 2-3 times (no audio can be listened) than all the problem come back again. Thats what i get in the log: (as a new user i cant post links sorry) h t t p s : / / p a s t e b i n . c o m / V A h e y 3 k g

Thank u in advance.

Line 162 of the paste:
31014 [2023-08-07 10:33:13] ERROR[2293] res_pjsip.c: Endpoint '0743539587': Could not create dialog to invalid URI '0743539587'. Is endpoint registered and reachable?

I assume that 0743539587 is the trunk name. In Reports → Asterisk Info, does the endpoint show as Registered? Does the log show Unreachable events for the trunk?

What did you change to get incoming calls to work?

If the trunk is registered and reachable, you might have some trunk setting that is blocking the outgoing INVITE. On the General tab, confirm that the trunk is not Disabled. Post screenshots of the pjsip General and Advanced tabs.

Hi, Stewart
To make inbound calls working i only removed CID AND DID in trunk and inbound route.
Dk why the trunk was offline in asterisk info (i noticed it but inbound calls were anyway working).
Anyway just removed the trunk and made it again, now it seems to be online.

Here it is the log of an outbound call after i deleted and remade the trunk.
h t t p s : / / p a s t e b i n . c o m / 3 K U Z t 3 W z

Edit: sorry, I was wrong here.

Sorry, I didn’t realize that 9-digit “old” mobiles still exist. So, we need pjsip logger to see what’s wrong.
At the Asterisk command prompt (not a shell prompt) type
pjsip set logger on
make a new test call and paste the log.

Hi, Thank u for helping me

Here it is.
h t t p s : / / p a s t e b i n . c o m / M T f M 0 J W A
(somewhere i can see forbidden from the trunk…)

Anyway I can see that if i put “From User to the same value you have in Username and From Domain to the same value you have in SIP Server” the trunk goes offline.

Line 321 of the paste:
54866 From: "200" <sip:[email protected]>;tag=15036d75-b620-48e9-9885-563e276b7926
This looks like you need to set From User and From Domain, but:

After you try an outbound call? Otherwise, this is strange because these parameters don’t affect registration nor incoming calls.

Try setting them up again and confirm that registration and inbound calling is still ok. Then turn pjsip logger back on (Apply config turns it off), try an outbound call and paste the log.

I did everything u asked. Added from user and from domain, saved, applied, rebootted the vm. The trunk seems to be offline (its red and unauthorized), anyway inbound calls works perfectly including dmtf.

Outbound calls are not working, here’s one of them log.
h t t p s : / / p a s t e b i n . c o m / N i P t e Q j 3

Indeed, that’s why the outbound call failed. At the Asterisk command prompt, type
pjsip show registration 0743539587
and post the output. Also, screenshots of the pjsip tabs of the trunk settings.

btw seems to be onn

ibb. co/5xvGMWh
ibb. co/xXGv1tC
ibb. co/vdrF3zM
ibb. co/J5bvbLV

Edit: i can see support outbound “no”

Registration is ok, so just guessing here, perhaps the trunk is not responding to OPTIONS (qualify). See whether setting Qualify Frequency to 0 helps. Or, (without setting it to 0), look at two minutes of the Asterisk log (no calls needed) to see whether OPTIONS requests are being sent and getting replies.

The fact is that when u told me first time to “From User to the same value you have in Username and From Domain to the same value you have in SIP Server”, 2-3 calls worked, afterthat no more.
Should i try reinstalling freepbx?

Edit: just set Qualify Frequency to 0 and now everything works. Dk how to thank u, u hella saved my life.

I haven’t seen strong evidence of its misbehavior (yet). Please paste ~3 minutes of the Asterisk log (with pjsip logger on), with no calls, so we can see qualify requests and replies.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.