Failed to contact the iSymphony server

I have just installed iSymphony through Module Admin update.

I am on FreePBX Asterisk (Ver. 11.7.0)

I got this error in iSymphonyV3 interface:

Failed to contact the iSymphony server.
Verify that your iSymphony server is installed and running and that the server API host and port are correct in the fields below.
If you have SSL enabled below and are using the SSL port for the API connection you need to enable SSL in the iSymphony server’s security.xml file for the communication_manager servlet.

After the default installation from module admin, do I need to do anything to configure? Or have I missed out any steps?

Thank you.

How did you install FreePBX? I assume not from the FreePBX Distro. If not then you would also need to install the iSymphony server piece.

I have update AsteriskNOW 3 by update script and got same error. Which modules need to be install by freepbx module admin?
[Asterisk API/Manager Users module][1]

Is this commercial modules by Schmooze?[1]:,+Elastix+and+PBX+in+a+Flash+Installation#FreePBX,ElastixandPBXinaFlashInstallation-5.FreePBXModuleInstallation

No its a commercial product by i9 technologies. What do you mean update AsteriskNOW 3. What script did you use?

AsteriskNOW download from Asterisk site. With the freepbx, I download from module admin which is same way as the freepbx distro.

Ok well iSymphony has a server piece that also has to be installed which the FreePBX Distro installs for you.

Thanks. Do you know where can I download the service piece for AsteriskNOW?

the i9 website I would think

It was the Conversiont Script

Instructions on iSymphony website says (

  1. install Java JDK or JRE;
  2. install and enable freepbx modules - Asterisk API and Manager Users;
  3. upload, install and enable freepbx iSymphony module.

But in Module Admin no exactly freepbx modules like Asterisk API and Manager Users.
Module Admin have modules like

  • REST API (its a commercial)
  • User Management
  • Asterisk Manager

Any ideas?

I have the same problem from a default install of the FreePBX distribution (FreePBX-5.211.65-12-i386-Full-1401071741). downloaded May 27, 2014. iSymphony server 1.4.8 and iSymphonyV3 3.1.2 client.

  1. From Admin - iSymphony, it shows the server is UP and running. .

Under Server Settings:
Admin User Name: admin
Admin Password: secret
Client Port: 50003

  1. From Admin - iSymphonyV3, it displays the message “Failed to contact the iSymphony server” plus under Server - Connected, it indicates NO in red.

Under Server API Connection Settings:
Port: 58080
Username: manager
Password: manag3rpa55word

Under Module Client Link Settings
Client Port: 58080

My guess is that these settings should match between the server and client but I’m not sure if this would affect the FreePBX database. I have found zero information on what the correct ports should be and how it integrates with FreePBX. Also since it is a default setup of the FreePBX distribution, I would expect that this would be set properly right out of the box.

Also FreePBX Admin - Mod Admin shows iSymphony as version 1.4.8 but Admin - iSymphony shows it as v2.8.2 rev 4975

I think that I found the problem. I am running OSS Endpoint Manager. But in order to disable the Commercial Endpoint Manager, you have to disable REST. I believe that iSymphony now needs REST in order to run. From iSymphonyV3 client log I see “(20 Jun 2014 09:19:29)-[DEBUG]: Starting REST connection to http://localhost:58080/communication_manager/api/resource/

Well, its works for me after:

  1. Download iSympony rpm
  2. rpm -Uvh iSymphonyServerV3--1.noarch.rpm (See iSymphony documentation
  3. service iSymphonyServerV3 restart

Does schmooze repo or freepbxdistro repo has iSymphonyServerV3 package?

Now I cant Log In.

I create fbpx administrator by module Administrators. The error appear when i try to login “Invalid username/password”. In log file same error. But a password is correct.

Uninstalling openjdk, installing JDK/JRE nothing change.

No you want to use our RPM. We have a special RPM in our repos already for this.

Yes the FreePBX distro has iSymphony server and client V3 installed. I’m pretty sure I broke it disabling REST which it needs to run.

As Tony mentioned, you install iSymphony through the FreePBX - Admin - Module Admin menus. It is already installed in the distro.

A few things to note:

  1. Disabling REST in FreePBX should not effect the REST communication between the iSymphony V3 FreePBX module and the the iSymphony V3 server as it utilizes its own rest library separate from FreePBX.

  2. The iSymphony FreePBX module version (reported in Admin->Module Admin) is different than the iSymphony Server version (reported in Admin->iSymphony/iSymphony V3).

  3. There are two iSymphony modules in the FreePBX repository for iSymphony one for Version 2 and one for Version 3. The module for version 3 has a version number of 3.0.0 and above.

  4. The Open JDK is not supported by the iSymphony V3 Server.

I does sound like there is a communication issue between the iSymphony FreePBX module and the iSymphony Server. I would need to see the following two logs to determine what the communication issue is:


If you do not want to post this information in a public place you can always open a ticket at