Fail2ban with custom ports

Hi Freepbx,

I use customized ports for ssh (port 22)and apache (port 80)
Now I customized these ports to other port numbers.
When I edit /etc/fail2ban/jail.local and change port=ssh to port=all, everything goes fine and ssh is banned at any port number. But when I use the freepbx syste admin module and save fail2ban settings, all settings are returned to port=ssh.

How can I solve this?
-Can I add a custom jail_additional.local that adds some settings?
-Is there a other way to ban custom ports for ssh or apache?

Many thanx in advance!

Found out that by default ssh is banned on other ports. so things should be ok by default? is that correct?

Also tried to ban myself when loggin in on freepbx gui with other port and also default port 80.
But I am not banned. (not on port 80 and not on custom web port)
Is that correct?